Opened 10 years ago

Closed 5 years ago

#4976 closed enhancement (fixed)

Hide user guide pages on the translation site

Reported by: humdinger Owned by: nobody
Priority: normal Milestone: R1
Component: Website/Userguide Translator Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

As discussed on the docs mailing list in topic Publishing the translated guides the working documents and maybe generated pages available from the translation site, should be protected from "leaking" out. All linkage and search engine results should point to the single location of the official Haiku User Guide.

Therefore, everything behind the start page with the login, should be protected by that authentification.

Koki should have put a robots.txt file in place for userguide.haikuzone.net already.

This authentification protection should be done immediately, so I put a prio=high on this ticket.

Change History (11)

comment:1 Changed 10 years ago by koki

Koki should have put a robots.txt file in place for userguide.haikuzone.net already.

FYI, this is done.

comment:2 Changed 10 years ago by VinDuv

Status: newassigned

The documents page is now restricted to logged in users. Direct access to /generated and view.php is still possible, though.

comment:3 Changed 8 years ago by deejam

Resolution: fixed
Status: in-progressclosed

Searching for "haiku site://i18n.haiku-os.org/" modified during the last year do not generate any search results (searching without any last modification date results in 29 matches).

Closing this ticket as fixed.

comment:4 Changed 8 years ago by humdinger

I think what was intended back when this ticket was filed, is that the access to everything under http://i18n.haiku-os.org/userguide/ is restricted and points toward the login page. Currently, entering the URL http://i18n.haiku-os.org/userguide/view.php?doc_id=71&l=de will show you a page even if you don't have an account.
Reopen?

comment:5 in reply to:  4 Changed 8 years ago by deejam

Priority: highnormal
Resolution: fixed
Status: closedreopened

Replying to humdinger:

I think what was intended back when this ticket was filed, is that the access to everything under http://i18n.haiku-os.org/userguide/ is restricted and points toward the login page.

Obviously I didn't read the entire mailing-list thread, I just read the ticket. I'll have to fix the exported documents. Since they are plain html pages, I need to make another solution. But that will solve another todo; moving all the generated files outside of the web-root.

In the current setup, any user that knows where files are stored (like Google) can open documents if they know the url. So I'll just move the export, import, source_repos and source_docs outside the web root and create a rule that searches for them. In that way, we can restrict access to logged on users using php.

Currently, entering the URL http://i18n.haiku-os.org/userguide/view.php?doc_id=71&l=de will show you a page even if you don't have an account.

Fixed in 45d8f3217776. As usual, it will be available on the next pull by Niels.

Reopen?

Sure. I also changed the priority to normal.

comment:6 Changed 8 years ago by deejam

Should be fixed in 70c52b0f3c77. The css won't work because of an error that will require me to rewrite a lot. So we have to live with that for a while.

I'm keeping this ticket open until you can verify that it works as intended.

comment:7 in reply to:  6 Changed 8 years ago by deejam

Replying to deejam:

The css won't work because of an error that will require me to rewrite a lot. So we have to live with that for a while.

Made a quick fix in ab77a56bcda1. It still needs to be fixed properly since I have more problems with that (stupid) idea of using a base variable when there are server variables for that usage.

comment:8 Changed 8 years ago by deejam

Owner: changed from VinDuv to deejam
Status: reopenedin-progress

comment:9 in reply to:  6 Changed 8 years ago by deejam

Replying to deejam:

Should be fixed in 70c52b0f3c77. The css won't work because of an error that will require me to rewrite a lot. So we have to live with that for a while.

I'm keeping this ticket open until you can verify that it works as intended.

I had to backout of this changeset. It needs some more loving.

comment:10 Changed 8 years ago by deejam

Owner: changed from deejam to nobody
Status: in-progressassigned

comment:11 Changed 5 years ago by pulkomandy

Resolution: fixed
Status: assignedclosed

Seems to work just fine now?

Note: See TracTickets for help on using tickets.