Opened 10 years ago

Closed 10 years ago

#5014 closed bug (duplicate)

PANIC: calling unlock_memory() on unmapped memory!

Reported by: andreasf Owned by: bonefish
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: #4431 Blocking:
Has a Patch: no Platform: x86

Description

KDL while running automake --gnu on real hardware:

Thread 34 "scsi scheduler" running on CPU 1
kdebug> bt
[...]
12 ... <kernel_x86>:unlock_memory_etc + 0x00d0
13 ... IOBuffer<...>::_UnlockMemory
14 IOBuffer<...>::UnlockMemory
15 IORequest<...>::NotifyFinished
16 IOScheduler<...>::_Finisher
17 IOScheduler<...>::_Scheduler
18 IOScheduler<...>::_SchedulerThread
19 _create_kernel_thread_kentry
20 thread_kthread_exit

Change History (3)

comment:1 by andreasf, 10 years ago

at hrev34117, GCC4 build, P4 w/HyperThreading

comment:2 by axeld, 10 years ago

Owner: changed from axeld to bonefish

comment:3 by bonefish, 10 years ago

Blocked By: 4431 added
Resolution: duplicate
Status: newclosed

Duplicate of #4431.

Note: See TracTickets for help on using tickets.