Opened 13 years ago

Closed 11 years ago

#502 closed bug (fixed)

Black interface parts in some apps

Reported by: diver Owned by: stippi
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by stippi)

You could see black parts in the following apps from R5:

Keyboard ScrollBar VirtualMemory NetPositive

Attachments (1)

keyboard.png (10.4 KB) - added by diver 13 years ago.
keyboard pref from R5

Download all attachments as: .zip

Change History (18)

comment:1 Changed 13 years ago by axeld

Fixed for Keyboard, ScrollBar, VirtualMemory in hrev17160. Problem remains in NetPostitive for some reason.

Changed 13 years ago by diver

Attachment: keyboard.png added

keyboard pref from R5

comment:2 Changed 13 years ago by axeld

The NetPositive problem seems to be a drawing engine bug. It looks like AS_FILL_RECT is called with the correct state:

pattern = 0 low color = {216, 216, 216}

But for some reason, the rectangle is drawn black.

comment:3 Changed 13 years ago by axeld

Owner: changed from axeld to stippi

comment:4 Changed 13 years ago by jackburton

Maybe it depends on the drawing state ? i.e. maybe it's B_OP_OVER/B_OP_ALPHA or something like that ?

comment:5 Changed 13 years ago by stippi

I could not reproduce it locally, though I had previously seen it. I must have some local change that fixed it, I will go over the diffs. I cannot commit as is, since some of my local stuff doesn't work yet 100%.

comment:6 Changed 13 years ago by stippi

Status: newassigned

comment:7 Changed 13 years ago by diver

Fixed in hrev17172.

comment:8 Changed 13 years ago by diver

Resolution: fixed

comment:9 Changed 13 years ago by diver

Status: assignedclosed

comment:10 Changed 13 years ago by diver

It seems that this bug is still there, see http://flickr.com/photos/ johndrinkwater/142668464/ Reopening.

comment:11 Changed 13 years ago by diver

Resolution: fixed

comment:12 Changed 13 years ago by diver

Status: closedreopened

comment:13 Changed 13 years ago by diver

Cc: john@… added

comment:14 Changed 12 years ago by stippi

Description: modified (diff)
Platform: All

I have not seen anything like this in ages, is it really still there?

comment:15 Changed 11 years ago by aldeck

Tested those four hrev5 apps, and more, with hrev23705 / vmware, can't reproduce.

comment:16 Changed 11 years ago by diver

Component: - GeneralKits/Interface Kit

Didn't see this bug over year now, i think it's safe to close it.

comment:17 Changed 11 years ago by aldeck

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.