Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#501 closed bug (fixed)

[Terminal] .profile

Reported by: diver Owned by: korli
Priority: normal Milestone: R1
Component: Applications Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

*1. I've added simple script to /boot/home/.profile. It changes terminal window title on change dir, but it wont work in Haiku

function path_title() { echo -en "\033]2;pwd\007" } PROMPT_COMMAND=path_title

*2. Also PS1='$PWD>' doesn't work either.

Attachments (1)

terminal_patch.txt (1.3 KB) - added by korli 13 years ago.
fix to set window title

Download all attachments as: .zip

Change History (16)

comment:1 Changed 13 years ago by korli

Your second item works here. Could you check it again ?

comment:2 Changed 13 years ago by korli

Cc: korli@… added

comment:3 Changed 13 years ago by diver

(In reply to comment #1)

Your second item works here. Could you check it again ?

Yep, the second one works now, it must be i wrote it wrong in .profile 1st item still there though.

comment:4 Changed 13 years ago by diver

Owner: changed from sikosis to korli@…

comment:5 Changed 13 years ago by korli

bug_group: developers

Changed 13 years ago by korli

Attachment: terminal_patch.txt added

fix to set window title

comment:6 Changed 13 years ago by korli

Resolution: fixed

comment:7 Changed 13 years ago by korli

fixed in revision 17250

comment:8 Changed 13 years ago by korli

Status: newclosed

comment:9 Changed 13 years ago by diver

blocked: 556

comment:10 Changed 13 years ago by diver

Status: closedreopened

comment:11 Changed 13 years ago by diver

After this fix i get sh crash whatever i type in terminal and press enter. It happens only if i have following lines in .profile

function path_title() { echo -en "\033]2;pwd\007" } PROMPT_COMMAND=path_title

See #556 for back trace. Reopening bug for now.

comment:12 Changed 13 years ago by diver

Resolution: fixed

comment:13 Changed 13 years ago by diver

Resolution: fixed

comment:14 Changed 13 years ago by diver

Status: reopenedclosed

comment:15 Changed 13 years ago by diver

Hmm, can't reproduce it anymore, probably fixed. Closing bug.

Note: See TracTickets for help on using tickets.