Opened 10 years ago

Closed 6 months ago

#5041 closed bug (invalid)

Install CD doesn't apply power to USB on Dell Dimension 3100

Reported by: MichaelCrawford Owned by: mmlr
Priority: normal Milestone: Unscheduled
Component: Drivers/USB Version: R1/Development
Keywords: USB, power, mouse, keyboard Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

See also #5040, in which safe video gets me to the blue screen, but then I have no mouse or keyboard.

When I boot a Dell Dimension 3100 from the hrev34248 installation CD using safe mode video, I get to the blue screen with the message saying "Do you wish to run the the Installer or continue booting to the Desktop?"

At that point I have no mouse or keyboard.

I think the problem is that USB bus power needs to be enabled in software. I have noticed that while running Windows XP, my optical mouse has no power until fairly late in the Windows boot.

This unit has no PS/2 ports, so I won't be able to use it until power can be enabled somehow.

I do own a USB hub that has a socket for external power, but it didn't come with a power supply. If I can dig one up I'll try powering the mouse and keyboard with the hub, but it may take some time to find one.

Change History (10)

comment:1 Changed 10 years ago by axeld

Component: User InterfaceDrivers/USB
Owner: changed from stippi to mmlr

If you don't know the component, leaving it untouched is probably the best thing to do.

comment:2 Changed 10 years ago by axeld

BTW please attach a syslog if possible - if there is no serial debug output, you can enable "on screen debug output" in the boot loader, and take photos.

This could likely be an interrupt issue.

comment:3 Changed 10 years ago by MichaelCrawford

I don't yet have an on-disk installation, but am just running the install CD. So I won't have a syslog.

I enabled the on-screen debug, then paged through a few screens until I got the screen with the following. At that point the debug pager no longer responded to the keyboard:

ohci: ohci_supports_device (might be ahci - hard to see clearly) usb uhci -1: successfully started the controller (repeats three more times) usb ohci: no devices found usb ehci -1: the host controller is bios owned usb ehci -1: claiming ownership of the host controller usb ehci -1: successfully took ownership of the host controller usb ehci -1: successfully started the controller usb hub 7: port 0: device removed usb hub 7: port 1: device removed usb hub 22: port 2: new device connected usb ehci 4: lowspeed device connected, giving up port ownership usb hub 22: port 3: new device connected usb ehci 4: lowspeed device connected, giving up power ownership

(some messages about the boot partition follow)

intel: ep_std_ops(0x1) intel: ep_std_ops(0x2)

(more partition stuff, then the two intel messages again)

Could it be that message about giving up port ownership?

comment:4 Changed 10 years ago by MichaelCrawford

oopsy... I didn't realize the lines would wrap. I can reenter it if you want me to.

comment:5 Changed 10 years ago by mmlr

That's really not how it works. You don't "enable" power manually. Powering the ports is part of resetting/enabling them and they are always enabled on boot. The more likely scenario is that you didn't wait long enough after booting the CD, so that the input_server wasn't yet running and the corresponding driver wasn't loaded. Please try/confirm.

comment:6 Changed 9 years ago by mmlr

Any new info on this? The on-screen debug output stops because when the USB controllers are initialized the legacy support in the BIOS, that enables the keyboard up to that point, is turned off. If you press "t" before that happens the paging will continue automatically after a few seconds delay on each page giving you some time to take a picture if necessary. If you have a USB 2.0 hub then can you please try hooking your input devices up to that one and see if they work then? If so then this is an OHCI issue.

comment:7 Changed 9 years ago by mmlr

Priority: blockernormal

Ping? In any case definitely not a blocker.

comment:8 Changed 4 years ago by MichaelCrawford

Long time no see.

I apologize for leaving this so many years. I live in Washington State now but left my Dell Dimension in storage in California with the assumption that I would quickly find work then have the cash to fetch my stuff with a U-Haul truck.

That this hasn't worked out is rather a sore point with me; just now I applied for a carpentry job.

I realized as I wrote my letter of application that I was always far, far happier working in construction than in any software industry job I have _ever_ had.

I enjoy writing code what I don't enjoy is working in what I regard as a profoundly corrupt industry.

I don't know that I'll get this specific carpentry job but I do know there is a significant construction boom in the Portland/Vancouver metro area and that I already own all of my own tools, everything from a contractor's (ie. not hobbyist) table saw to a full-size blacksmith's anvil.

I still want to fetch all that stuff. I'll find some other kind of work Real Soon Now; I expect I can complete on this bug by the end of the year, possibly by mid-Autumn. Maybe the bug no longer occurs but if it does quite likely I can write the patch that closes it.

comment:9 Changed 14 months ago by cocobean

hrev52017 tested. I think we can close this bug based on Michael Lotz's notes. No issue reproduced on my end.

comment:10 Changed 6 months ago by waddlesplash

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.