Opened 9 years ago

Closed 7 years ago

#5040 closed bug (fixed)

Dell Dimension 3100 with LCD screen loses video at end of boot

Reported by: MichaelCrawford Owned by: axeld
Priority: high Milestone: Unscheduled
Component: Drivers/Graphics/intel_extreme Version: R1/Development
Keywords: r34248, video, boot, safe mode, vga Cc:
Blocked By: Blocking: #7662
Has a Patch: no Platform: x86

Description

This bug occurred while booting the x86 GCC2 Hybrid ISO on a CD-R, version hrev34248 - 2009-11-25.

I have a Dell Dimension 3100 that has an Intel 82915G / GV / 910 GL Express Chipset for the video, according to the Windows XP device manager. It has a 2.8 GHz Pentium 4 and 1 GB of RAM.

The video card has only a VGA connection - no DVI. I have it connected to a 1400 by 900 Acer AL1917W A LCD display with a VGA-to-VGA cable.

When Haiku boots, I see the progress of the boot icons, then the screen goes black, with the display's firmware showing the message "Adjusting Config". I think that might mean it has been set to an unsupported resolution. After a few seconds the config message disappears and then the screen just stays black.

I tried several of the safe video modes. Standard VGA ended up with a screen that was mostly black, but with some small white bars right at the top of the screen. All the other video modes were totally black.

The unit doesn't have a serial port, but if a PCI serial card would work for debugging I could plug one in.

I have some DVI video cards that might work, but this particular configuration should be supported.

I speculate that what is happening is that the safe video mode is retained only during the progress of the boot, with the mode being changed to other values at the end of boot, perhaps as a result of auto-detecting the display's normal resolution.

I'd like to learn to write Haiku hardware drivers. If you can give me a little hand-holding, maybe I can debug this myself.

I'll get back to you with the results of trying a DVI video card.

Change History (18)

comment:1 Changed 9 years ago by bonefish

A syslog would help tremendously. If you have some Linux installed, you can mount your BFS partition using the "befs" file system. It would also be interesting to know whether an earlier Haiku revision worked on this machine.

My guess is that hrev34206 causes the problem.

comment:2 Changed 9 years ago by MichaelCrawford

bonefish - I can set up Linux on this box, but it will take a little while. I don't want to blow away the hard drive that's in there, but I have some spares I can use.

I'll try the DVI card right now, then I'll set up Linux and try the VGA again.

comment:3 in reply to:  2 Changed 9 years ago by bonefish

Replying to MichaelCrawford:

bonefish - I can set up Linux on this box, but it will take a little while. I don't want to blow away the hard drive that's in there, but I have some spares I can use.

A live CD will do.

comment:4 Changed 9 years ago by axeld

Component: Audio & VideoDrivers/Graphics/intel_extreme
Owner: changed from nobody to axeld

Since the boot screen is visible, have you tried enabling "Use fail-safe video mode" in the boot loader's safe mode settings?

comment:5 Changed 9 years ago by MichaelCrawford

This unit has only PCI slots, no AGP. I bought a PCI DVI card a while back, but can't seem to find it. So I can't test DVI tonight.

I'll swap out the disk drive then try the build just before hrev34206, and I'll also set up linux so I can retrieve a syslog.

axeld - I hadn't seen the separate fail-safe video in the safe mode options. I was only looking at the other list of video modes. With fail-safe video it comes up to the blue screen that asks about running the installer.

Unfortunately I can't proceed from there because it doesn't respond to the USB mouse or keyboard. The unit doesn't have PS/2 ports. Should USB be able to work?

comment:6 Changed 9 years ago by axeld

Priority: blockerhigh

USB should work indeed, but that's obviously a different issue - the black screen is then just caused by the intel extreme driver.

The easiest solution would be to disable the device support for the time being - I can't test it here, anyway.

comment:7 Changed 9 years ago by MichaelCrawford

See #5041 for the USB problem - I think power needs to be enabled in software. Windows does it, but Haiku doesn't, at least not when my unit needs it.

comment:8 Changed 9 years ago by axeld

BTW you didn't try with an earlier version of Haiku, right? So this may not be a recent problem?

comment:9 Changed 9 years ago by MichaelCrawford

axeld - no, just the latest so far. But I'm happy to try earlier versions to find where the problem appeared.

comment:10 Changed 9 years ago by umccullough

Sounds like a similar intel_extreme issue that a lot of i945 chips are suffering from (see also #4240, #3464, #3149 )

When you're on the boot menu, selecting a mode from the "fail safe video modes" doesn't actually make the app_server use fail safe video (only the boot screen) - if you want the app_server to use fail safe video, you must go into the safe mode options sub-menu and turn on the fail safe video mode also. This will prevent app_server from using the intel_extreme driver beyond boot screen and likely provide you with a usable vesa system.

FWIW, this is extremely confusing to explain to people who aren't familiar with it - could something be done to remove the ambiguity here?

comment:11 in reply to:  8 Changed 9 years ago by umccullough

Also reference #4406

comment:12 Changed 9 years ago by umccullough

I tested R1/Alpha1 on my wife's ASUS desktop computer which has an i915 chipset, and after the boot screen logos are all lit, the screen goes black for a second, and then comes back with a shifted image of the boot screen with some artifacts at the bottom corner at which point it hangs.

This is booting from USB stick, btw, the screen is a 1920x1200 LCD attached to the VGA port (no DVI port on this box), machine has 2gb RAM.

I can get into KDL from this point - but the KDL output is also shifted and wraps around the screen slightly, it seems the framebuffer alignment is all screwed up at this point.

I tried a somewhat newer revision (from last week I believe), but it keeps hanging at the disk icon (the R1/Alpha1 did this one one of the boot attempts also). I'll try an even newer one soon.

If I set fail safe video mode, R1/Alpha1 boots to a desktop just fine.

What can I provide that might help? I can hook a serial cable to the machine if necessary, or take photos of the screen state if necessary.

comment:13 Changed 9 years ago by umccullough

listdev output from the ASUS machine:

~> listdev

device Serial bus controller (SMBus) [c|5|0]
  vendor 8086: Intel Corporation
  device 266a: 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller

device Mass storage controller (IDE interface) [1|1|8f]
  vendor 8086: Intel Corporation
  device 2651: 82801FB/FW (ICH6/ICH6W) SATA Controller

device Mass storage controller (IDE interface) [1|1|8a]
  vendor 8086: Intel Corporation
  device 266f: 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller

device Bridge (ISA bridge) [6|1|0]
  vendor 8086: Intel Corporation
  device 2640: 82801FB/FR (ICH6/ICH6R) LPC Interface Bridge

device Network controller (Ethernet controller) [2|0|0]
  vendor 8086: Intel Corporation
  device 1076: 82541GI Gigabit Ethernet Controller

device Bridge (PCI bridge, Subtractive decode) [6|4|1]
  vendor 8086: Intel Corporation
  device 244e: 82801 PCI Bridge

device Serial bus controller (USB Controller, EHCI) [c|3|20]
  vendor 8086: Intel Corporation
  device 265c: 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller

device Serial bus controller (USB Controller, UHCI) [c|3|0]
  vendor 8086: Intel Corporation
  device 265b: 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4

device Serial bus controller (USB Controller, UHCI) [c|3|0]
  vendor 8086: Intel Corporation
  device 265a: 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3

device Serial bus controller (USB Controller, UHCI) [c|3|0]
  vendor 8086: Intel Corporation
  device 2659: 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2

device Serial bus controller (USB Controller, UHCI) [c|3|0]
  vendor 8086: Intel Corporation
  device 2658: 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1

device Bridge (PCI bridge, Normal decode) [6|4|0]
  vendor 8086: Intel Corporation
  device 2666: 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 4

device Bridge (PCI bridge, Normal decode) [6|4|0]
  vendor 8086: Intel Corporation
  device 2664: 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 3

device Bridge (PCI bridge, Normal decode) [6|4|0]
  vendor 8086: Intel Corporation
  device 2662: 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 2

device Bridge (PCI bridge, Normal decode) [6|4|0]
  vendor 8086: Intel Corporation
  device 2660: 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1

device Multimedia controller (Audio device) [4|3|0]
  vendor 8086: Intel Corporation
  device 2668: 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller

device Display controller [3|80|0]
  vendor 8086: Intel Corporation
  device 2782: 82915G Integrated Graphics Controller

device Display controller (VGA compatible controller, VGA controller) [3|0|0]
  vendor 8086: Intel Corporation
  device 2582: 82915G/GV/910GL Integrated Graphics Controller

device Bridge (Host bridge) [6|0|0]
  vendor 8086: Intel Corporation
  device 2580: 82915G/P/GV/GL/PL/910GL Memory Controller Hub

comment:14 Changed 9 years ago by umccullough

Confirmed same with hrev34164 (hang at disk icon subsided after ~10 minutes).

comment:15 Changed 9 years ago by MichaelCrawford

I'm afraid there has been a misunderstanding, with the result that I won't get to keep this computer.

My housemate runs an e-Waste recycling center; when I found the computer on our front porch, I assumed it was being donated, and put the arm on it myself. But it turns out that my housemate had left it out to be picked up by a friend of his. So I'm going to have to put it back out on our front porch, and won't be able to test Haiku on it anymore.

I have another recycled PC I can use for real hardware testing, but it probably won't experience the same set of bugs.

comment:16 Changed 8 years ago by scottmc

Blocking: 7662 added

comment:17 Changed 7 years ago by umccullough

At least, the machine I had that was experiencing issues with intel_extreme on i915 works fine now, so I'm going to close this bug as fixed.

comment:18 Changed 7 years ago by umccullough

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.