Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#5054 closed bug (invalid)

BeZillaBrowser does not show JPEG images anymore

Reported by: stippi Owned by: mmadia
Priority: normal Milestone: R1
Component: Applications Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I don't know which revision this started on, but now I have made a clean image again and this problem is still there. On any webpage, BeZillaBrowser does not show JPEG images. Am I the only one with this problem? What additional information can I supply that would be helpful?

Change History (6)

comment:1 by augiedoggie, 10 years ago

I thought there was already a closed ticket for this but I can't find it. Maybe it's at haiku-ports. Usually this is caused by conflicting versions of libjpeg.

rm /boot/common/lib/libjpeg*

fixes it for me.

comment:2 by augiedoggie, 10 years ago

I forgot to mention that if you use netsurf or BeHappy you will need to copy the libraries to the appropriate place before you remove them. I'm not in Haiku at the moment to give the exact paths, but, basically you want something like:

mkdir /boot/apps/BeHappy/lib
cp -a /boot/common/lib/libjpeg* /boot/apps/BeHappy/lib

mkdir /boot/apps/netsurf/lib
cp -a /boot/common/lib/libjpeg* /boot/apps/netsurf/lib

comment:3 by mmadia, 10 years ago

http://dev.osdrawer.net/issues/386 explains the issue. Basically bezilla utilizes haiku's png, jpeg, and z libraries. Since some optional packeges also provide them, a collision occurs. Can you try copying or symlinking haiku's pubs into beziila/libs?

comment:4 by axeld, 10 years ago

Resolution: invalid
Status: newclosed

This is obviously a package error then; other packages should not replace libjpeg.so with a incompatible version.

I just don't understand why it's not compatible, as it doesn't really change that often.

comment:5 by stippi, 10 years ago

This is indeed a package error, but packages are still managed by Haiku, so IMHO, a bug here, even if additional to a ticket at haiku-ports, is valid.

comment:6 by axeld, 10 years ago

I think that depends if it's part of an "official" optional package, that is one that we intend to include with Haiku.

If there already is a ticket open on haiku ports, I don't think we need another one here for the same problem, but I don't really care either (just that we still have so many open bugs left :-)).

Note: See TracTickets for help on using tickets.