Opened 9 years ago

Closed 9 years ago

#5057 closed bug (fixed)

ASF_reader crashes while playing an WMA file ...

Reported by: herdemir Owned by: dlmcpaul
Priority: normal Milestone: R1
Component: Audio & Video/Codecs Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

[Switching to team /boot/system/apps/MediaPlayer (1040) thread playback manager (1045)]
0x00922b17 in __udivdi3 () from /boot/system/lib/libroot.so
(gdb) bt
#0  0x00922b17 in __udivdi3 () from /boot/system/lib/libroot.so
#1  0x00a0ad8f in asf_seek_to_msec ()
   from /boot/system/add-ons/media/plugins/asf_reader
#2  0x00a08ea0 in ASFFileReader::ParseIndex ()
   from /boot/system/add-ons/media/plugins/asf_reader
#3  0x00a0891f in ASFFileReader::ParseFile ()
   from /boot/system/add-ons/media/plugins/asf_reader
#4  0x00a06a31 in asfReader::Sniff ()
   from /boot/system/add-ons/media/plugins/asf_reader
#5  0x005abe93 in BPrivate::media::PluginManager::CreateReader ()
   from /boot/system/lib/libmedia.so
#6  0x005aa260 in BPrivate::media::MediaExtractor::MediaExtractor ()
   from /boot/system/lib/libmedia.so
#7  0x0057e72b in BMediaFile::_InitReader () from /boot/system/lib/libmedia.so
#8  0x0057d95e in BMediaFile::BMediaFile () from /boot/system/lib/libmedia.so
#9  0x0024e8c2 in FilePlaylistItem::CreateMediaFile ()
#10 0x00265f51 in Controller::SetTo ()
#11 0x002659fe in Controller::MessageReceived ()
#12 0x0035ae83 in BLooper::DispatchMessage () from /boot/system/lib/libbe.so
#13 0x0035c7f1 in BLooper::task_looper () from /boot/system/lib/libbe.so
#14 0x0035c3df in BLooper::_task0_ () from /boot/system/lib/libbe.so
#15 0x0092abce in thread_entry () from /boot/system/lib/libroot.so
#16 0x70080fec in ?? ()

Revision used hrev34370. Can provide the audio file if it's needed.

Change History (5)

comment:1 Changed 9 years ago by dlmcpaul

Owner: changed from nobody to dlmcpaul

Well there are 3 opportunities for a divide error in that function. either time_interval, packet_size or max_bitrate could be 0.

So a test file to reproduce the issue would be good.

comment:2 Changed 9 years ago by axeld

Fixing them all wouldn't hurt either, I guess ;-)

But a test file is always welcome for this kind of problems.

comment:3 Changed 9 years ago by dlmcpaul

Well, I could put a guard statement on all of them but at the very least time_interval and packet size should not be 0, max_bitrate I am not so sure of.

I suspect the issue is in how those values were read from the file.

comment:4 Changed 9 years ago by herdemir

comment:5 Changed 9 years ago by dlmcpaul

Resolution: fixed
Status: newclosed

Try hrev34431

The file has an index header but no index entries.

So I am decoding it by assuming that each packet is a constant size. Looks to work ok.

Note: See TracTickets for help on using tickets.