Opened 10 years ago

Closed 11 months ago

#5058 closed bug (invalid)

NetPenguin's liblayout.so needs to be replaced

Reported by: humdinger Owned by: nobody
Priority: normal Milestone: R1
Component: System/libroot.so Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev34375, gcc4 hybrid (though this bug appeared at least since IIRC hrev34234).

NetPenguin crashes when connecting to a ftp server:

[Switching to team /boot/apps/NetPenguin-1.64/NetPenguin (414) thread w>Connected To: 192.168.178.1 (431)]
0x002fccb5 in MScrollView::layout () from /boot/apps/NetPenguin-1.64/lib/liblayout.so
(gdb) bt
#0  0x002fccb5 in MScrollView::layout () from /boot/apps/NetPenguin-1.64/lib/liblayout.so
#1  0x00308e4c in VGroup::layout () from /boot/apps/NetPenguin-1.64/lib/liblayout.so
#2  0x002f1d55 in HGroup::layout () from /boot/apps/NetPenguin-1.64/lib/liblayout.so
#3  0x002f371d in MBorder::layout () from /boot/apps/NetPenguin-1.64/lib/liblayout.so
#4  0x00308e4c in VGroup::layout () from /boot/apps/NetPenguin-1.64/lib/liblayout.so
#5  0x003037eb in MWindow::FrameResized () from /boot/apps/NetPenguin-1.64/lib/liblayout.so
#6  0x004bf2c0 in BWindow::DispatchMessage () from /boot/system/lib/gcc2/libbe.so
#7  0x004c484c in BWindow::task_looper () from /boot/system/lib/gcc2/libbe.so
#8  0x004017cf in BLooper::_task0_ () from /boot/system/lib/gcc2/libbe.so
#9  0x006d2bce in thread_entry () from /boot/system/lib/gcc2/libroot.so
#10 0x70143fec in ?? ()

Since it's the same NetPenguin archive, I guess the fault is in /boot/system/lib/gcc2/libroot.so (?)

Change History (12)

comment:1 by stippi, 10 years ago

Without having looked at the code, this could be a problem with when our BScrollView creates it's scroll bars, or maybe this is a binary compatibility problem in case Marco changed some private members to public to access them in his copy of the ScrollView.h header (but that's really only a wild guess).

comment:2 by bbjimmy, 10 years ago

same error running gcc2 hybrid hrev24761. this is not a gcc4 issue.

in reply to:  2 comment:3 by bbjimmy, 10 years ago

Accordong to this post... http://www.haikuware.com/remository/view-details/internet-network/ftp/netpenguin#comment-4927

NetPenguin runs ok if the liblayout.so inckuded in the package is replaced with liblayout.so from WonderBrush.

I tried it and it works. Is this an hrev5 compatibility issue?

comment:4 by humdinger, 9 years ago

Thanks for that tip, bbjimmy!

comment:5 by stippi, 9 years ago

Either NetPenguin has been packaged with the wrong liblayout.so, or it is indeed an issue with Haiku not being binary compatible with the version from NetPenguin. It would be nice to get the complete debugger output, i.e. with the line that mentions the cause of the crash.

comment:6 by humdinger, 9 years ago

This is the comlete output:

[tcsetpgrp failed in terminal_inferior: Invalid Argument]
Thread 2603 caused an exception: Segment violation
Reading symbols from /boot/system/runtime_loader...done.
Loaded symbols for /boot/system/runtime_loader
Reading symbols from /boot/apps/NetPenguin-1.64/lib/liblayout.so...done.
Loaded symbols for /boot/apps/NetPenguin-1.64/lib/liblayout.so
Reading symbols from /boot/system/lib/gcc2/libbe.so...done.
Loaded symbols for /boot/system/lib/gcc2/libbe.so
Reading symbols from /boot/system/lib/gcc2/libmedia.so...done.
Loaded symbols for /boot/system/lib/gcc2/libmedia.so
Reading symbols from /boot/system/lib/gcc2/libnetwork.so...done.
Loaded symbols for /boot/system/lib/gcc2/libnetwork.so
Reading symbols from /boot/system/lib/gcc2/libbnetapi.so...done.
Loaded symbols for /boot/system/lib/gcc2/libbnetapi.so
Reading symbols from /boot/system/lib/gcc2/libroot.so...done.
Loaded symbols for /boot/system/lib/gcc2/libroot.so
Reading symbols from /boot/system/lib/gcc2/libtextencoding.so...done.
Loaded symbols for /boot/system/lib/gcc2/libtextencoding.so
Reading symbols from /boot/system/lib/gcc2/libtracker.so...done.
Loaded symbols for /boot/system/lib/gcc2/libtracker.so
Reading symbols from /boot/system/lib/gcc2/libtranslation.so...done.
Loaded symbols for /boot/system/lib/gcc2/libtranslation.so
Reading symbols from /boot/system/lib/gcc2/libstdc++.r4.so...done.
Loaded symbols for /boot/system/lib/gcc2/libstdc++.r4.so
Reading symbols from /boot/system/add-ons/Translators/gcc2/BMPTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/gcc2/BMPTranslator
Reading symbols from /boot/system/add-ons/Translators/gcc2/EXRTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/gcc2/EXRTranslator
Reading symbols from /boot/system/lib/gcc2/libilmimf.so...done.
Loaded symbols for /boot/system/lib/gcc2/libilmimf.so
Reading symbols from /boot/system/lib/gcc2/libz.so.1...done.
Loaded symbols for /boot/system/lib/gcc2/libz.so.1
Reading symbols from /boot/system/add-ons/Translators/gcc2/GIFTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/gcc2/GIFTranslator
Reading symbols from /boot/system/add-ons/Translators/gcc2/ICOTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/gcc2/ICOTranslator
Reading symbols from /boot/system/add-ons/Translators/gcc2/JPEG2000Translator...done.
Loaded symbols for /boot/system/add-ons/Translators/gcc2/JPEG2000Translator
Reading symbols from /boot/system/add-ons/Translators/gcc2/JPEGTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/gcc2/JPEGTranslator
Reading symbols from /boot/system/lib/gcc2/libjpeg.so.8.0...done.
Loaded symbols for /boot/system/lib/gcc2/libjpeg.so.8.0
Reading symbols from /boot/system/add-ons/Translators/gcc2/PCXTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/gcc2/PCXTranslator
Reading symbols from /boot/system/add-ons/Translators/gcc2/PNGTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/gcc2/PNGTranslator
Reading symbols from /boot/system/add-ons/Translators/gcc2/PPMTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/gcc2/PPMTranslator
Reading symbols from /boot/system/add-ons/Translators/gcc2/RAWTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/gcc2/RAWTranslator
Reading symbols from /boot/system/add-ons/Translators/gcc2/RTF-Translator...done.
Loaded symbols for /boot/system/add-ons/Translators/gcc2/RTF-Translator
Reading symbols from /boot/system/add-ons/Translators/gcc2/SGITranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/gcc2/SGITranslator
Reading symbols from /boot/system/add-ons/Translators/gcc2/STXTTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/gcc2/STXTTranslator
Reading symbols from /boot/system/add-ons/Translators/gcc2/TGATranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/gcc2/TGATranslator
Reading symbols from /boot/system/add-ons/Translators/gcc2/TIFFTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/gcc2/TIFFTranslator
Reading symbols from /boot/system/lib/gcc2/libtiff.so.3.8...done.
Loaded symbols for /boot/system/lib/gcc2/libtiff.so.3.8
Reading symbols from /boot/system/add-ons/Translators/gcc2/WonderBrushTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/gcc2/WonderBrushTranslator
[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /boot/apps/NetPenguin-1.64/NetPenguin (2585) thread w>Connected To: 192.168.178.1 (2603)]
0x002fccb5 in MScrollView::layout ()
   from /boot/apps/NetPenguin-1.64/lib/liblayout.so
(gdb) bt
#0  0x002fccb5 in MScrollView::layout ()
   from /boot/apps/NetPenguin-1.64/lib/liblayout.so
#1  0x00308e4c in VGroup::layout ()
   from /boot/apps/NetPenguin-1.64/lib/liblayout.so
#2  0x002f1d55 in HGroup::layout ()
   from /boot/apps/NetPenguin-1.64/lib/liblayout.so
#3  0x002f371d in MBorder::layout ()
   from /boot/apps/NetPenguin-1.64/lib/liblayout.so
#4  0x00308e4c in VGroup::layout ()
   from /boot/apps/NetPenguin-1.64/lib/liblayout.so
#5  0x003037eb in MWindow::FrameResized ()
   from /boot/apps/NetPenguin-1.64/lib/liblayout.so
#6  0x004c6ac0 in BWindow::DispatchMessage ()
   from /boot/system/lib/gcc2/libbe.so
#7  0x004cc054 in BWindow::task_looper () from /boot/system/lib/gcc2/libbe.so
#8  0x00407d97 in BLooper::_task0_ () from /boot/system/lib/gcc2/libbe.so
#9  0x006eafe6 in thread_entry () from /boot/system/lib/gcc2/libroot.so
#10 0x70143fec in ?? ()
(gdb) 

Since this same package has been working in the past, it's probably not the fault of the packaged liblayout.so.

comment:7 by mmadia, 9 years ago

Summary: NetPenguin crashes when connectingNetPenguin's liblayout.so needs to be replaced

A solution is to install Haiku's LibLayout and delete NetPenguin's liblayout.* file.

Quoted from #haiku on freenode.net:

[22:53:51] <mmadia> how'd you fix NetPenguin the other day?
[22:53:54] <kirilla> yes, you need to delete liblayout from NetPenguins lib folder
[22:54:04] <saivert> r39341
[22:54:21] <kirilla> and if you haven't got liblayout already, use installoptinolpackage -a liblayout (?)
[22:54:22] <saivert> so just renaming to _liblayout.so doesn't do it?
[22:54:39] <kirilla> well, there's no use for it anymore, the old beos version
[22:55:42] <kirilla> installoptionalpackage -a LibLayout
[22:56:27] <kirilla> saivert: are you sure you're use a gcc2 hybrid (or pure gcc2) ?
[22:56:44] <kirilla> it won't work on a pure gcc4 haiku

comment:8 by stippi, 6 years ago

Unfortunately, the liblayout.so which can be installed via package management, triggers another error: The be_bold_font symbol is missing. The version which is contained in WonderBrush is the one which seems to work. Why don't we use that version for the "official" package?

in reply to:  8 comment:9 by augiedoggie, 6 years ago

Replying to stippi:

Unfortunately, the liblayout.so which can be installed via package management, triggers another error: The be_bold_font symbol is missing. The version which is contained in WonderBrush is the one which seems to work. Why don't we use that version for the "official" package?

We used to use an R5 based liblayout package before PM. I had specifically asked scott to keep using this version but he ignored me. So, perhaps he has a reason.

comment:10 by pulkomandy, 5 years ago

I had a similar issue (missing be_bold_font) in libGL because it wasn't linked against libbe. Maybe the same fix can be applied to liblayout? (just add -lbe to the linker flags).

comment:11 by axeld, 2 years ago

Owner: changed from axeld to nobody
Status: newassigned

comment:12 by waddlesplash, 11 months ago

Resolution: invalid
Status: assignedclosed

At any rate, that's not an issue with Haiku.

Note: See TracTickets for help on using tickets.