Opened 10 years ago

Closed 9 years ago

#5067 closed bug (fixed)

mail_daemon crashes when net connection is down

Reported by: humdinger Owned by: bga
Priority: normal Milestone: R1
Component: Servers/mail_daemon Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev34405.

When I pull the network cable and check for new mail, mail_daemon crashes like this:

[Switching to team /boot/system/servers/mail_daemon -E (117) thread j.seemer@gmx.de (7552)]
0x00a47eb5 in SSL_shutdown () from /boot/common/lib/libssl.so.0.9.8
(gdb) bt
#0  0x00a47eb5 in SSL_shutdown () from /boot/common/lib/libssl.so.0.9.8
#1  0x00a8ab14 in ?? () from /boot/system/add-ons/mail_daemon/inbound_protocols/POP3
#2  0x188ce840 in ?? ()
#3  0x70184a8c in ?? ()
#4  0x00a8ab14 in ?? () from /boot/system/add-ons/mail_daemon/inbound_protocols/POP3
#5  0x188ce840 in ?? ()
#6  0x00000000 in ?? ()
#7  0x70184aac in ?? ()
#8  0x00a8729e in POP3Protocol::~POP3Protocol ()
   from /boot/system/add-ons/mail_daemon/inbound_protocols/POP3
#9  0x0055ee3a in BMailChainRunner::MessageReceived () from /boot/system/lib/libmail.so
#10 0x003b460d in BLooper::DispatchMessage () from /boot/system/lib/libbe.so
#11 0x003b6169 in BLooper::task_looper () from /boot/system/lib/libbe.so
#12 0x003b5e30 in BLooper::_task0_ () from /boot/system/lib/libbe.so
#13 0x0023a9bb in thread_entry () from /boot/system/lib/libroot.so
#14 0x70184fec in ?? ()

Change History (3)

comment:1 by anevilyak, 10 years ago

Would you be able to look in your syslog and see if it has a corresponding backtrace as well? If so, please paste here (it uses a different mechanism for resolving the backtrace which might shed some light on the unresolved frames in that trace).

comment:2 by humdinger, 10 years ago

Here you go, sir:

KERN: vm_soft_fault: va 0x31644000 not covered by area in address space
KERN: vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x3164498c, ip 0xa47eb5, write 0, user 1, thread 0x126
KERN: vm_page_fault: thread "is.ingenieure@gmx.de" (294) in team "mail_daemon" (117) tried to read address 0x3164498c, ip 0xa47eb5 ("libssl.so.0.9.8_seg0ro" +0x28eb5)
KERN: debug_server: Thread 294 entered the debugger: Segment violation
KERN: stack trace, current PC 0xa47eb5  SSL_shutdown + 0x15:
KERN:   (0x701c5aac)  0x55ee3a  _ZN16BMailChainRunner15MessageReceivedEP8BMessage + 0xe4
KERN:   (0x701c5f3c)  0x3b460d  _ZN7BLooper15DispatchMessageEP8BMessageP8BHandler + 0x55
KERN:   (0x701c5f5c)  0x3b6169  _ZN7BLooper11task_looperEv + 0x205
KERN:   (0x701c5f9c)  0x3b5e30  _ZN7BLooper7_task0_EPv + 0x30
KERN:   (0x701c5fbc)  0x23a9bb  thread_entry + 0x2d
KERN: vm_soft_fault: va 0x0 not covered by area in address space
KERN: vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x1f, ip 0xa47eb5, write 0, user 1, thread 0x122
KERN: vm_page_fault: thread "Humdinger" (290) in team "mail_daemon" (117) tried to read address 0x1f, ip 0xa47eb5 ("libssl.so.0.9.8_seg0ro" +0x28eb5)

Thanks.

comment:3 by humdinger, 9 years ago

Resolution: fixed
Status: newclosed

Can't reproduce any more with hrev40924. Clemens has probably fixed it while working on the mail system. Thanks! Closing as fixed.

Note: See TracTickets for help on using tickets.