Opened 10 years ago

Closed 9 months ago

#5086 closed bug (fixed)

DHCP broken on sis900 network adapter.

Reported by: bbjimmy Owned by: nobody
Priority: normal Milestone: R1
Component: Network & Internet/Stack Version: R1/alpha2
Keywords: Cc: planche2k@…, siarzhuk, pascal.penners@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

hrev34494 using sis900 cannot ping the gateway ... 100% packet loss

ping 192.168.2.1 PING 192.168.2.1 (192.168.2.1): 56 data bytes 8 packets transmitted, 0 packets received, 100% packet loss

ifconfig /dev/net/sis900/0

Hardware Type: Ethernet, Address: 00:11:54b:d5:bd:b5 Media Type: 100Mbit, 100BASE - TX inet addr: 192.168.2.10 MTU: 1500, Metric: 0, up broadcast link auto-configured Receive: 2 packets, 1 errors, 459 bytes, 0 mcasts, 0 dropped Transmit: 32 packets, 39 errors, 9472 bytes, 0 mcasts, 0 dropped Collisions: 0

Attachments (3)

syslog (477.0 KB ) - added by bbjimmy 10 years ago.
syslog
screenshot1.png (139.1 KB ) - added by bbjimmy 10 years ago.
screenshot
syslog-DHCP.AF (404.2 KB ) - added by andreasf 9 years ago.
syslog

Download all attachments as: .zip

Change History (20)

comment:1 by bbjimmy, 10 years ago

I set the network to a static ip instead of DHCP. Still no luck with the network. I rebooted with the static ip still set and the networking started working, DHCP finds the ip, gateway, and ip dns addresses, but will not use them. to get the system to use them one must set the network to use static ip and re-boot.

comment:2 by axeld, 10 years ago

What was the last revision that worked for you?

comment:3 by andreasf, 10 years ago

Cc: planche2k@… added

comment:4 by bbjimmy, 10 years ago

This is the first time that DHCP received the gateway and dns ip addresses. I have always needed to use a static ip. This is the first time changing to a static ip has not allowed me to connect until I rebooted the system. This must be due to recent changes to DHCP, one step forward and two steps back.

in reply to:  4 comment:5 by siarzhuk, 10 years ago

Cc: siarzhuk added

Replying to bbjimmy:

This is the first time that DHCP received the gateway and dns ip addresses. I have

Does mean that some packets were transmitted and received. And the problem occure some time later.

always needed to use a static ip. This is the first time changing to a static ip has not allowed me to connect until I rebooted the system. This must be due to recent changes to DHCP, one step forward and two steps back.

I cannot confirm this - both my rtl8139 and rtl8169 networks are working well now. DHCP is function now - both at the system start and after re-plugging network cable during working system session all DHCP operations go OK. Your problem looks like a hardware-dependent issue. May be you shold acquire a syslog and attach it to this ticket?

by bbjimmy, 10 years ago

Attachment: syslog added

syslog

by bbjimmy, 10 years ago

Attachment: screenshot1.png added

screenshot

comment:6 by bbjimmy, 10 years ago

I see track lost my comment when I uploaded the screenshot and syslog. It seems that I was mistaken ... the ip, dns and gateway were left over from the last time I set a static ip and not found by DHCP. setting to static will not work until I reboot. It always has worked without rebooting in the past. DHCP it seems is still broken on the sis900 network adapter.

comment:7 by bbjimmy, 9 years ago

Summary: networking is completely deadDHCP broken on sis900 network adapter.

This ticket should be changed to "DHCP broken on sis900 network adapter."

comment:8 by bbjimmy, 9 years ago

As of hrev35938 DHCP is now working on my sis900 network adapter. This ticket can be closed.

comment:9 by stippi, 9 years ago

Resolution: fixed
Status: newclosed

Oh, nice. Thanks for the note!

comment:10 by andreasf, 9 years ago

Resolution: fixed
Status: closedreopened

DHCP is still not working at hrev35945 here, static IP does work.

Possibly related: the Ethernet address is shown as 00:00:00:00:00:00.

by andreasf, 9 years ago

Attachment: syslog-DHCP.AF added

syslog

in reply to:  10 comment:11 by anevilyak, 9 years ago

Replying to andreasf:

Possibly related: the Ethernet address is shown as 00:00:00:00:00:00.

That's probably due to this entry from your syslog:

KERN: sis900: could not get MAC address

comment:12 by axeld, 9 years ago

That should indeed be the problem here. You may want to look at the linux/FreeBSD driver if they do something special to retrieve the MAC address with that PHY/revision combination.

comment:13 by Cytor, 9 years ago

Cc: pascal.penners@… added
Platform: Allx86
Version: R1/DevelopmentR1/alpha2

Doesn't work here for me in alpha2.

The adapter receives a random IP address after some time. Setting a static IP doesn't work here, too. When I try to set it back to DHCP and click apply, the network application completely hangs with the apply-button remaining in the pressed state. This also happened after I inserted an old 3com adapter in parallel. I could only get it to work when disabling the sis900 in the bios setup.

comment:14 by stargatefan, 8 years ago

dupe of 4968

in reply to:  14 comment:15 by luroh, 8 years ago

Replying to stargatefan:

dupe of #4968

Perhaps, slightly different hardware revision though so might be worth keeping both around. I'll add a comment to #4968.

comment:16 by axeld, 2 years ago

Owner: changed from axeld to nobody
Status: reopenedassigned

comment:17 by waddlesplash, 9 months ago

Resolution: fixed
Status: assignedclosed

Probably fixed by switching SiS 900 to use the FreeBSD driver in hrev52675.

Note: See TracTickets for help on using tickets.