Opened 10 years ago

Closed 10 years ago

#5091 closed bug (fixed)

build of icu data broken

Reported by: Wizard Owned by: zooey
Priority: normal Milestone: R1
Component: Kits/Locale Kit Version: R1/Development
Keywords: ppc icu Cc:
Blocked By: Blocking:
Has a Patch: no Platform: PowerPC

Description

GenerateBreakIterator1 generated/objects/darwin/ppc/common/icudt42l/brkitr/word_POSIX.brk generated/objects/darwin/ppc/release/tools/icu/genbrk/genbrk: can not initialize ICU. status = U_FILE_ACCESS_ERROR

export DYLD_LIBRARY_PATH=$DYLD_LIBRARY_PATH:generated/objects/darwin/lib generated/objects/darwin/ppc/release/tools/icu/genbrk/genbrk -c -i generated/objects/darwin/ppc/common/icudt42l -r src/libs/icu/source/data/brkitr/word_POSIX.txt -o generated/objects/darwin/ppc/common/icudt42l/brkitr/word_POSIX.brk >/dev/null

...failed GenerateBreakIterator1 generated/objects/darwin/ppc/common/icudt42l/brkitr/word_POSIX.brk ...

Change History (7)

comment:1 by Wizard, 10 years ago

revision: 34514 building haiku/ppc on leopard/ppc

comment:2 by anevilyak, 10 years ago

Component: Build SystemKits/Locale Kit
Owner: changed from bonefish to zooey

comment:4 by Wizard, 10 years ago

also happens on linux/ppc

comment:5 by zooey, 10 years ago

Status: newassigned

This problem is caused by an open TODO in our ICU jamfiles: ICU is currently hardcoded to little-endian architectures, so it won't work on PPC hosts.

Looking into it, although I can't promise much, as I do not own any big-endian system to test with ...

comment:6 by zooey, 10 years ago

Status: assignednew

I have implemented support for building ICU on big-endian hosts in hrev34864. However, I have not been able to test this.

Please retest with hrev34864 or newer and reopen this bug if that didn't fix it.

comment:7 by zooey, 10 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.