Opened 10 years ago

Closed 9 years ago

#5121 closed bug (fixed)

Deskbar crash in TTeamMenuItem::Teams ()

Reported by: damoklas Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Deskbar Version: R1/Development
Keywords: deskbar Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description (last modified by siarzhuk)

Deskbar crash at full lenght by kliking twice on blue list. hrev34648

GNU gdb 6.3
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i586-pc-haiku"...(no debugging symbols found)

[tcsetpgrp failed in terminal_inferior: Invalid Argument]
Thread 197 caused an exception: Segment violation
Reading symbols from /boot/system/runtime_loader...done.
Loaded symbols for /boot/system/runtime_loader
Reading symbols from /boot/system/lib/libbe.so...done.
Loaded symbols for /boot/system/lib/libbe.so
Reading symbols from /boot/system/lib/libtracker.so...done.
Loaded symbols for /boot/system/lib/libtracker.so
Reading symbols from /boot/system/lib/libroot.so...done.
Loaded symbols for /boot/system/lib/libroot.so
Reading symbols from /boot/system/lib/libstdc++.r4.so...done.
Loaded symbols for /boot/system/lib/libstdc++.r4.so
Reading symbols from /boot/system/lib/libtranslation.so...done.
Loaded symbols for /boot/system/lib/libtranslation.so
Reading symbols from /boot/system/lib/libtextencoding.so...done.
Loaded symbols for /boot/system/lib/libtextencoding.so
Reading symbols from /boot/common/bin/KeymapSwitcher...done.
Loaded symbols for /boot/common/bin/KeymapSwitcher
Reading symbols from /boot/system/apps/NetworkStatus...done.
Loaded symbols for /boot/system/apps/NetworkStatus
Reading symbols from /boot/system/lib/libnetwork.so...done.
Loaded symbols for /boot/system/lib/libnetwork.so
Reading symbols from /boot/system/apps/ProcessController...done.
Loaded symbols for /boot/system/apps/ProcessController
Reading symbols from /boot/system/bin/desklink...done.
Loaded symbols for /boot/system/bin/desklink
Reading symbols from /boot/system/lib/libmedia.so...done.
Loaded symbols for /boot/system/lib/libmedia.so
Reading symbols from /boot/system/servers/mail_daemon...done.
Loaded symbols for /boot/system/servers/mail_daemon
Reading symbols from /boot/system/lib/libmail.so...done.
Loaded symbols for /boot/system/lib/libmail.so
Reading symbols from /boot/apps/Romashka/Romashka...done.
Loaded symbols for /boot/apps/Romashka/Romashka
Reading symbols from /boot/system/add-ons/Translators/BMPTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/BMPTranslator
Reading symbols from /boot/system/add-ons/Translators/EXRTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/EXRTranslator
Reading symbols from /boot/system/lib/libilmimf.so...done.
Loaded symbols for /boot/system/lib/libilmimf.so
Reading symbols from /boot/system/lib/libz.so...done.
Loaded symbols for /boot/system/lib/libz.so
Reading symbols from /boot/system/add-ons/Translators/GIFTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/GIFTranslator
Reading symbols from /boot/system/add-ons/Translators/ICOTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/ICOTranslator
Reading symbols from /boot/system/add-ons/Translators/JPEG2000Translator...done.
Loaded symbols for /boot/system/add-ons/Translators/JPEG2000Translator
Reading symbols from /boot/system/add-ons/Translators/JPEGTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/JPEGTranslator
Reading symbols from /boot/system/add-ons/Translators/PCXTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/PCXTranslator
Reading symbols from /boot/system/add-ons/Translators/PNGTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/PNGTranslator
Reading symbols from /boot/system/add-ons/Translators/PPMTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/PPMTranslator
Reading symbols from /boot/system/add-ons/Translators/RAWTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/RAWTranslator
Reading symbols from /boot/system/add-ons/Translators/RTF-Translator...done.
Loaded symbols for /boot/system/add-ons/Translators/RTF-Translator
Reading symbols from /boot/system/add-ons/Translators/SGITranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/SGITranslator
Reading symbols from /boot/system/add-ons/Translators/STXTTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/STXTTranslator
Reading symbols from /boot/system/add-ons/Translators/TGATranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/TGATranslator
Reading symbols from /boot/system/add-ons/Translators/TIFFTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/TIFFTranslator
Reading symbols from /boot/system/add-ons/Translators/WonderBrushTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/WonderBrushTranslator
[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /boot/system/Deskbar (105) thread w>Deskbar (197)]
0x0023a3d2 in TTeamMenuItem::Teams ()
(gdb) bt
#0  0x0023a3d2 in TTeamMenuItem::Teams ()
#1  0x0022ed17 in TExpandoMenuBar::MouseDown ()
#2  0x003e36cf in BWindow::DispatchMessage () from /boot/system/lib/libbe.so
#3  0x002298d8 in TBarWindow::DispatchMessage ()
#4  0x003e83b4 in BWindow::task_looper () from /boot/system/lib/libbe.so
#5  0x00324c53 in BLooper::_task0_ () from /boot/system/lib/libbe.so
#6  0x006eac3e in thread_entry () from /boot/system/lib/libroot.so
#7  0x78102fec in ?? ()
(gdb) 

Attachments (1)

deskbar-crash-fix.diff (531 bytes ) - added by darkwyrm 9 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 by damoklas, 10 years ago

Leaf-menu not list, sorry.

comment:2 by HaikuBot, 10 years ago

100% reproducible:

  1. Move Deskbar as a bar along the upper or lower border.
  2. Double Click on Leaf Menu and you ger crash.

comment:3 by siarzhuk, 10 years ago

Description: modified (diff)

comment:4 by anevilyak, 10 years ago

Component: User InterfaceApplications/Deskbar
Owner: changed from stippi to axeld

I think I even remember this one being reported (but never fixed) back in the days of OpenTracker...

comment:5 by anevilyak, 10 years ago

Version: R1/alpha1R1/Development

in reply to:  4 comment:6 by damoklas, 10 years ago

I'm check, on BeOS Deskbar v5.2.1 is OK.

comment:7 by damoklas, 10 years ago

Haiku rev. 35546, Deskbar still crash.

comment:8 by diver, 10 years ago

Summary: Deskbar crashDeskbar crash in TTeamMenuItem::Teams ()

comment:9 by streak, 10 years ago

Any progress since? Deskbar still crashing in #35878 :/

comment:10 by darkwyrm, 9 years ago

Clicking slowly on the leaf button does not cause the crash. The crash is caused by a NULL pointer reference on item in the double-click-related code at the bottom of MouseDown. Attaching a patch until I get commit access squared away.

by darkwyrm, 9 years ago

Attachment: deskbar-crash-fix.diff added

comment:11 by axeld, 9 years ago

Status: newin-progress

comment:12 by axeld, 9 years ago

Resolution: fixed
Status: in-progressclosed

Thanks, fixed in hrev36389.

Note: See TracTickets for help on using tickets.