Opened 10 years ago

Closed 10 years ago

#5120 closed bug (duplicate)

Error shutting down media_addon_server

Reported by: jahaiku Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Servers/media_addon_server Version: R1/alpha1
Keywords: Cc:
Blocked By: #5150 Blocking:
Has a Patch: no Platform: All

Description

Sometimes at shutting down Haiku I get the following error:

125: DEBUGGER: getNumAvailable() < getNumBlocks()
debug_server: Thread 125 entered the debugger: Debugger call: `getNumAvailable() < getNumBlocks()'
stack trace, current PC 0xffff0114  :
  (0x7ffeec10)  0x5b6efb  __assert_fail + 0x46
  (0x7ffeec30)  0x5bf4ba  _ZN8BPrivate9hoardHeap9freeBlockERPNS_5blockERPNS_10superblockEiPNS_11processHeapE + 0x388
  (0x7ffeec70)  0x5c0882  _ZN8BPrivate11processHeap4freeEPv + 0x298
  (0x7ffeecd0)  0x5c206a  free + 0x154
  (0x7ffeecf0)  0x4f5763  _ZdlPv + 0x23
  (0x7ffeed10)  0x4a630f  _ZNSt8_Rb_treeIllSt9_IdentityIlESt4lessIlESaIlEE5eraseESt17_Rb_tree_iteratorIlES7_ + 0x8d
  (0x7ffeed40)  0x4a6361  _ZNSt8_Rb_treeIllSt9_IdentityIlESt4lessIlESaIlEE5eraseERKl + 0x37
  (0x7ffeed70)  0x4a5ef0  _ZN8BPrivate5media8PortPool7GetPortEv + 0x64
  (0x7ffeeda0)  0x4a5f8f  _ZN8BPrivate5media12request_dataC2Ev + 0x1f
  (0x7ffeedc0)  0x48da40  _ZN8BPrivate5media14BMediaRosterExC1EPl + 0x36
  (0x7ffeee30)  0x48dc13  _ZN12BMediaRoster6RosterEPl + 0xdb
  (0x7ffeee70)  0x489ce0  _ZN10BMediaNode7ReleaseEv + 0x34
  (0x7ffeee90)  0x4a8ea0  _ZN8BPrivate5media23TimeSourceObjectManagerD1Ev + 0x42
  (0x7ffeeec0)  0x4a8f5e  _Z41__static_initialization_and_destruction_0ii + 0x4f
  (0x7ffeeee0)  0x4a8f7b  _GLOBAL__D_TimeSourceObjectManager.cpp + 0x15
  (0x7ffeeef0)  0x47a8f8  (/boot/system/lib/libmedia.so + 0x48)
  (0x7ffeef00)  0x4af024  (/boot/system/lib/libmedia.so + 0x10)
  (0x7ffeef0c)  0x100507  terminate_program + 0x7a
  (0x7ffeef4c)  0x61a0fc  exit + 0x70
  (0x7ffeef6c)  0x2082a5  _start + 0x59
  (0x7ffeef9c)  0x1052b7  runtime_loader + 0x12f
virtual void AddOnManager::MessageReceived(BMessage*) what: nDSS
debug_server: Killing team 125 (/boot/system/servers/media_addon_server)
debug_server: TeamDebugHandler::Init(): Failed to get info for team 125: Operation on invalid team
debug_server: KillTeam(): Error getting info for team 125: Operation on invalid team
debug_server: Killing team 125 ()

This is from the serial syslog console. It is a actual gcc4 build.

Change History (2)

comment:1 Changed 10 years ago by jahaiku

I forgot to say that is was in qemu and not on real hardware. Perhaps this is the same as in my new ticket, but the stack trace is different.

comment:2 Changed 10 years ago by axeld

Blocked By: 5150 added
Resolution: duplicate
Status: newclosed

Duplicate of #5150 (and fixed in hrev34906).

Note: See TracTickets for help on using tickets.