Opened 9 years ago

Closed 9 years ago

#5215 closed bug (duplicate)

Assert in vm_page.cpp while booting under VMWare.

Reported by: bga Owned by: bonefish
Priority: critical Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: #5208 Blocking:
Has a Patch: no Platform: All

Description

After a long time without compiling Haiku, I decided to give it another go to check Ingo's changes (nice work, BTW) and tried to boot the latest revision (hrev34945) under VMWare. I was sent to KDL right after the boot screen showed up with the following assert:

PANIC: ASSERT FAILED (src/system/kernel/vm/vm_page.cpp:2286): page->state != PAGE_STATE_FREE && page->state != PAGE_STATE_CLEAR

KDL screen capture with backtrace is attached.

Attachments (1)

kdl.png (18.4 KB) - added by bga 9 years ago.

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by bga

Attachment: kdl.png added

comment:1 Changed 9 years ago by mmlr

Blocked By: 5208 added
Version: R1/alpha1R1/Development

Duplicate of #5208.

comment:2 Changed 9 years ago by bonefish

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.