Opened 9 years ago

Closed 9 years ago

#5351 closed bug (fixed)

Tracker crashes after Show navigator is on.

Reported by: mt Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/Development
Keywords: BPictureButton Cc:
Blocked By: #5361 Blocking:
Has a Patch: no Platform: All

Description

Tracker crashes after Single window navigation and Show navigator are on.
Tested hrev35383, gcc4/gcc2 hybrid, real hardware.

GNU gdb 6.3
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i586-pc-haiku"...(no debugging symbols found)

[tcsetpgrp failed in terminal_inferior: Invalid Argument]
Thread 1056 called debugger(): Need to set the 'disabled' pictures for this BPictureButton 
Reading symbols from /boot/system/runtime_loader...done.
Loaded symbols for /boot/system/runtime_loader
Reading symbols from /boot/system/lib/libbe.so...done.
Loaded symbols for /boot/system/lib/libbe.so
Reading symbols from /boot/system/lib/libtracker.so...done.
Loaded symbols for /boot/system/lib/libtracker.so
Reading symbols from /boot/system/lib/libroot.so...done.
Loaded symbols for /boot/system/lib/libroot.so
Reading symbols from /boot/system/lib/libstdc++.so...done.
Loaded symbols for /boot/system/lib/libstdc++.so
Reading symbols from /boot/system/lib/libtranslation.so...done.
Loaded symbols for /boot/system/lib/libtranslation.so
Reading symbols from /boot/system/lib/libtextencoding.so...done.
Loaded symbols for /boot/system/lib/libtextencoding.so
Reading symbols from /boot/system/lib/libsupc++.so...done.
Loaded symbols for /boot/system/lib/libsupc++.so
Reading symbols from /boot/system/add-ons/Translators/BMPTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/BMPTranslator
Reading symbols from /boot/system/add-ons/Translators/EXRTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/EXRTranslator
Reading symbols from /boot/system/lib/libilmimf.so...done.
Loaded symbols for /boot/system/lib/libilmimf.so
Reading symbols from /boot/system/lib/libz.so.1...done.
Loaded symbols for /boot/system/lib/libz.so.1
Reading symbols from /boot/system/add-ons/Translators/GIFTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/GIFTranslator
Reading symbols from /boot/system/add-ons/Translators/ICOTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/ICOTranslator
Reading symbols from /boot/system/add-ons/Translators/JPEG2000Translator...done.
Loaded symbols for /boot/system/add-ons/Translators/JPEG2000Translator
Reading symbols from /boot/system/add-ons/Translators/JPEGTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/JPEGTranslator
Reading symbols from /boot/system/lib/libjpeg.so.8.0...done.
Loaded symbols for /boot/system/lib/libjpeg.so.8.0
Reading symbols from /boot/system/add-ons/Translators/PCXTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/PCXTranslator
Reading symbols from /boot/system/add-ons/Translators/PNGTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/PNGTranslator
Reading symbols from /boot/system/add-ons/Translators/PPMTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/PPMTranslator
Reading symbols from /boot/system/add-ons/Translators/RAWTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/RAWTranslator
Reading symbols from /boot/system/add-ons/Translators/RTF-Translator...done.
Loaded symbols for /boot/system/add-ons/Translators/RTF-Translator
Reading symbols from /boot/system/add-ons/Translators/SGITranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/SGITranslator
Reading symbols from /boot/system/add-ons/Translators/STXTTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/STXTTranslator
Reading symbols from /boot/system/add-ons/Translators/TGATranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/TGATranslator
Reading symbols from /boot/system/add-ons/Translators/TIFFTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/TIFFTranslator
Reading symbols from /boot/system/add-ons/Translators/WonderBrushTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/WonderBrushTranslator
[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /boot/system/Tracker (1041) thread w>src (1056)]
0xffff0114 in ?? ()
(gdb) bt
#0  0xffff0114 in ?? ()
#1  0x005dffa3 in debugger () from /boot/system/lib/libroot.so
#2  0x0030abc8 in BPictureButton::Draw () from /boot/system/lib/libbe.so
#3  0x00355288 in BView::_Draw () from /boot/system/lib/libbe.so
#4  0x0035fb81 in BWindow::DispatchMessage () from /boot/system/lib/libbe.so
#5  0x0035b6ed in BWindow::task_looper () from /boot/system/lib/libbe.so
#6  0x002aa6d2 in BLooper::_task0_ () from /boot/system/lib/libbe.so
#7  0x005e3ca0 in thread_entry () from /boot/system/lib/libroot.so
#8  0x701c5fec in ?? ()
(gdb) 

Change History (7)

comment:1 Changed 9 years ago by anevilyak

I've seen this every once in a while and it seems to be resource-related somehow. The one time I tried to debug it though, it went away after adding debug code, and then didn't recur after reverting. Not sure what's going on with that unless it's some weird race in either the build sys or xres.

comment:2 Changed 9 years ago by anevilyak

Can you by any chance confirm that the icons for disks and/or individual volumes are also missing?

comment:3 Changed 9 years ago by anevilyak

I'm starting to suspect a possible bug in one of libroot_build or libbe_build ... I'm completely unable to reproduce this problem with a libtracker.so built within Haiku, it only manifests itself when I cross build it from FreeBSD, and even then not reliably. Also it looks like more than just resources are affected after all, nav menus with the faulty libtracker often show incorrect icons for folders, but the Haiku-built one does not.

comment:4 in reply to:  3 Changed 9 years ago by mt

Replying to anvilyak:

Can you by any chance confirm that the icons for disks and/or individual volumes are also missing?

Yes, Some icons are missing (boot disk, home, develop, preferences, system

Replying to anevilyak:

it only manifests itself when I cross build it from FreeBSD, and even then not reliably.

I cross build with Ubuntu 9.10

comment:5 Changed 9 years ago by anevilyak

Blocked By: 5361 added

comment:6 Changed 9 years ago by bonefish

Blocked By: 5361 removed

(In #5361) Via binary search I've identified hrev35396 as the revision that introduced the problem. Will investigate.

AFAICT it doesn't seem to be related to #5351. At least I can reliably reproduce the problem with hrev35396 or later while everything works fine here with earlier revisions.

comment:6 Changed 9 years ago by bonefish

Blocked By: 5361 added
Resolution: fixed
Status: newclosed

Fixed in hrev35407.

Note: See TracTickets for help on using tickets.