Opened 9 years ago

Closed 9 years ago

#5357 closed bug (fixed)

/usr/bin/ld: warning: libbe_build.so, needed by <generated.x86gcc2>/objects/freebsd/lib/libicu-i18n.so, not found (try using -rpath or -rpath-link)

Reported by: mmadia Owned by: nobody
Priority: normal Milestone: R1
Component: Build System Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This has occurred a few times, though at this point I'm not sure if it's a dependency issue in ICU's jamfiles or a bug in jam, similar to the jam -qjN bash with N>1.

Cross-compiling x86-gcc2 or gcc4 from FreeBSD 8.0 32bit. In an empty generated directory,

configure --use-gcc-pipe --use-xattr <set cross-tools prefix>
jam -q bash
jam -q -j8 @alpha-cd

The issue is not with @alpha-cd. Rather it's the first target to be built after bash. There has been at least one occasion where @alpha-cd and the target after that failed to build.

Assigning to Oliver, in hopes that the issue is a missing dependency.

Attachments (2)

jam-x86gcc4-35389-alpha-cd.log (79.7 KB) - added by mmadia 9 years ago.
log snippet
jam-x86gcc4-35389-alpha-cd.log.gz (42.0 KB) - added by mmadia 9 years ago.
full log, gzipped.

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by mmadia

log snippet

Changed 9 years ago by mmadia

full log, gzipped.

comment:1 Changed 9 years ago by zooey

Owner: changed from zooey to nobody
Status: newassigned

I've checked the dependencies, but while there was an inconsistency (no need to depend on libbe_build.so at all) I have not been able to either reproduce nor find a possible cause for this problem.

Jam reports the correct dependencies on <build>libicu-i18n.so, so I really have no idea what's going on.

comment:2 Changed 9 years ago by mmadia

Resolution: fixed
Status: assignedclosed

hrev35638 seems to have fixed it. The warning message no longer occurs when building either hrev35640 gcc2 or gcc4 in FreeBSD 7.2. Thanks!

Note: See TracTickets for help on using tickets.