Opened 9 years ago

Closed 9 years ago

#5385 closed bug (duplicate)

SegFault when shutting down Haiku

Reported by: jahaiku Owned by: nobody
Priority: normal Milestone: R1
Component: Servers/media_addon_server Version: R1/alpha1
Keywords: Cc:
Blocked By: #5863 Blocking:
Has a Patch: no Platform: All

Description

This is a gcc4 build of hrev35431. I got this while shutting down haiku.

vm_soft_fault: va 0x0 not covered by area in address space
vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x0, ip 0x0, write 0, user 1, thread 0x9f
vm_page_fault: thread "Audio Mixer control" (159) in team "media_addon_server" (128) tried to read address 0x0, ip 0x0 ("???" +0x0)
debug_server: Thread 159 entered the debugger: Segment violation
stack trace, current PC (nil)  :
  (0x70180e6c)  0x48d04c  _ZN10BMediaNode14WaitForMessageExmPv + 0x10a
  (0x70184eac)  0x487e46  _ZN17BMediaEventLooper11ControlLoopEv + 0x1f6
  (0x70184f9c)  0x48785f  _ZN17BMediaEventLooper19_ControlThreadStartEPv + 0x27
  (0x70184fbc)  0x5b4ca0  thread_entry + 0x2d

Change History (2)

comment:1 Changed 9 years ago by marcusoverhagen

Owner: changed from marcusoverhagen to nobody
Status: newassigned

comment:2 Changed 9 years ago by bonefish

Blocked By: 5863 added
Resolution: duplicate
Status: assignedclosed

Not idea how I missed this ticket. Closing as duplicate of #5863 which has more info attached.

Note: See TracTickets for help on using tickets.