Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#540 closed bug (invalid)

DevFS should lowercase /dev entries

Reported by: johndrinkwater Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version:
Keywords: Cc: diver
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The nV driver currently publishes its /dev/graphics entry in uppercase, but the BeOS kernel converts it to lowercase; whereas Haiku perserves the case. Rudolf is changing this behaviour, but I thought i'd report the incompatiblity.

Change History (5)

comment:1 Changed 13 years ago by diver

Cc: diver added

comment:2 Changed 13 years ago by axeld

I just checked and R5 definitely doesn't lowercase exported drivers. Whatever was responsible for this effect, that wasn't the cause.

comment:3 Changed 13 years ago by axeld

Resolution: invalid

comment:4 Changed 13 years ago by axeld

Status: newclosed

comment:5 Changed 13 years ago by johndrinkwater

Maybe Rudolfs build system doesnt understand the difference between X and x. Anyhow, driver doesnt do this anymore, so closing.

Note: See TracTickets for help on using tickets.