Opened 10 years ago

Closed 10 years ago

#5409 closed bug (duplicate)

Invalid concurrent access to page

Reported by: jahaiku Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/alpha1
Keywords: Cc:
Blocked By: #5404 Blocking:
Has a Patch: no Platform: All

Description

I was configuring rsync and got this error on a gcc4 build of hrev35455. Screenshot attached...

Attachments (1)

error1.png (52.5 KB ) - added by jahaiku 10 years ago.

Download all attachments as: .zip

Change History (4)

by jahaiku, 10 years ago

Attachment: error1.png added

comment:1 by bonefish, 10 years ago

Blocked By: 5404 added
Resolution: duplicate
Status: newclosed

Duplicate of #5404.

comment:2 by bonefish, 10 years ago

Blocked By: 5404 removed

comment:3 by bonefish, 10 years ago

Blocked By: 5404 added

(In #5404) Replying to andreasf:

Yes. There's a Makefile variable NO_MMAP but I don't set it, so it will use mmap at some point.

Thanks, that supports my suspicion that this is indeed the same problem as #5409 where an mmap()ed area is deleted while the page writer writes back one of its modified pages.

@jahaiku: Sorry for removing you from the CC. Trac is really annoying w.r.t. concurrent ticket changes.

Note: See TracTickets for help on using tickets.