Opened 9 years ago

Closed 9 years ago

#5404 closed bug (fixed)

Invalid concurrent page access

Reported by: andreasf Owned by: bonefish
Priority: high Milestone: R1
Component: - General Version: R1/Development
Keywords: Cc: Jens.Arm@…
Blocked By: Blocking: #5409
Has a Patch: no Platform: x86

Description

Got this at hrev35458 while running git-rebase, while it was re-applying the local commits:

PANIC: Invalid concurrent access to page 0x82c03ddc (start), currently accessed by: 7
Welcome to Kernel Debugging Land...
Thread 22630 "git" running on CPU 1
kdebug> 

The system is frozen, so KDL cannot be used to get more info.

It looks similar to my earlier #5359, but there have been no further problems at boot time.

Change History (7)

comment:1 Changed 9 years ago by bonefish

Cc: bonefish removed
Owner: changed from nobody to bonefish
Status: newassigned

Assuming that thread 7 is the page writer, that might be a problem Axel pointed me to recently. Do you know by any chance whether git uses mmap() for I/O?

Regarding the hanging KDL, in case you use a USB keyboard, you need to enter KDL manually at least once or it won't work on programmatic panic()s.

comment:2 Changed 9 years ago by bonefish

Blocking: 5409 added

(In #5409) Duplicate of #5404.

comment:3 Changed 9 years ago by jahaiku

Cc: Jens.Arm@… added

comment:4 Changed 9 years ago by bonefish

Blocking: 5409 removed
Cc: Jens.Arm@… removed
Status: assignedin-progress

comment:5 in reply to:  1 Changed 9 years ago by andreasf

Replying to bonefish:

Do you know by any chance whether git uses mmap() for I/O?

Yes. There's a Makefile variable NO_MMAP but I don't set it, so it will use mmap at some point.

comment:6 Changed 9 years ago by bonefish

Blocking: 5409 added
Cc: Jens.Arm@… added

Replying to andreasf:

Yes. There's a Makefile variable NO_MMAP but I don't set it, so it will use mmap at some point.

Thanks, that supports my suspicion that this is indeed the same problem as #5409 where an mmap()ed area is deleted while the page writer writes back one of its modified pages.

@jahaiku: Sorry for removing you from the CC. Trac is really annoying w.r.t. concurrent ticket changes.

comment:7 Changed 9 years ago by bonefish

Resolution: fixed
Status: in-progressclosed

Fixed in hrev35485.

Note: See TracTickets for help on using tickets.