Opened 10 years ago

Closed 10 years ago

#5462 closed bug (duplicate)

Boot hangs right after the disk icon

Reported by: aldeck Owned by: nobody
Priority: normal Milestone: R1
Component: - General Version: R1/Development
Keywords: boot hang disk icon Cc:
Blocked By: #5421 Blocking:
Has a Patch: no Platform: All

Description

I've noticed that recently, on real hardware on first boot after a fresh build (no update-all). I now submit this ticket since it just happened again with qemu/linux, 1cpu, no kqemu, clean working copy, full rebuild. It's pretty hard to reproduce unfortunately, had it only two times in the first ten tries, then it vanished... with the following sequence: rm haiku.image; jam; qemu haiku.image
I don't seem to be able to reproduce after the image has booted/hung once.
hrev35589, gcc2/4 hybrid
I wasn't able to enter KDL manually, but that might be due to qemu, been a long time since i've used it.
See attached serial log

Attachments (1)

serial_hang_1st_boot.log (19.9 KB ) - added by aldeck 10 years ago.

Download all attachments as: .zip

Change History (2)

by aldeck, 10 years ago

Attachment: serial_hang_1st_boot.log added

comment:1 by bonefish, 10 years ago

Blocked By: 5421 added
Resolution: duplicate
Status: newclosed

In such cases please get a stack trace of the "main2" thread and, even better, try to find out why it doesn't continue.

In qemu pressing Alt-Sysreq-D doesn't work. You have to press (left) Ctrl-Alt-2 to enter the qemu monitor and execute the command sendkey alt-sysrq-d (no typo, it's really "sysrq"). Get back via Ctrl-Alt-1.

Anyway, I've seen something like this a few times already and it was always #5421. Just from the syslog its not possible to verify or disprove it, so I'm closing the ticket as a duplicate. Please reopen, when you encounter it next time and can retrieve information that suggests otherwise.

Note: See TracTickets for help on using tickets.