Opened 10 years ago

Closed 3 years ago

Last modified 3 years ago

#5514 closed bug (no change required)

BeHappy does not work due to NetSurf libraries not being in a system lib dir.

Reported by: bga Owned by: mmu_man
Priority: normal Milestone: R1
Component: Applications Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

BeHappy needs NetSurf and there is a dependency rule, which is fine. The problem is that BeHappy loads NetSurf as a replicant and, due to that, NetSurf can not find its libraries (they are inside a lib dir in its directory) and BeHappy fails to load due to that. I guess the solution would be to provide the required NetSurf libraries (I think it is only libmng or something like that) as a separate optional package so it would be installed in some system wide lib dir. Either that or remove BeHappy, as it simply does not work as it is.

Change History (10)

comment:1 by bga, 10 years ago

Owner: changed from nobody to scottmc
Status: newassigned

comment:2 by scottmc, 10 years ago

Summary: BeHappy does notwork due to NetSurf ligbraries not being in a system lib dir.BeHappy does not work due to NetSurf libraries not being in a system lib dir.

comment:4 by scottmc, 8 years ago

Owner: changed from scottmc to nobody

comment:5 by scottmc, 8 years ago

Version: R1/DevelopmentR1/alpha3

comment:6 by mmadia, 8 years ago

Version: R1/alpha3R1/Development

R1 Alpha 3 has not yet been released. This was with an R1 Alpha 3 Release Candidate image.

comment:7 by pulkomandy, 5 years ago

Owner: changed from nobody to mmu_man

comment:8 by pulkomandy, 3 years ago

Resolution: no change required
Status: assignedclosed

This should be handled by the HaikuPorts team, now. (and BeHappy should be made gcc4 to work with current NetSurf versions).

comment:9 by richienyhus, 3 years ago

Isn't more an issue for BeHappy's repo and not HaikuPorts? https://github.com/mmuman/BeHappy

comment:10 by pulkomandy, 3 years ago

Actually the first step would be to fix NetSurf's replicant support. But this particular issue was about libraries being installed in the wrong place, which is something to solve on HaikuPorts side (if not already done).

Note: See TracTickets for help on using tickets.