Opened 10 years ago

Closed 9 years ago

#5531 closed bug (duplicate)

ACPI errors on Acer Aspire One AOA150 / ZG5

Reported by: kallisti5 Owned by: nobody
Priority: normal Milestone: R1/alpha2
Component: Drivers/ACPI Version: R1/Development
Keywords: Cc: fredrik.holmqvist@…
Blocked By: #5449 Blocking:
Has a Patch: no Platform: x86

Description

hrev35731

KERN: acpi: ACPI disabled
KERN: acpi: ACPI disabled
KERN: smp: using ACPI to detect MP configuration
KERN: CPU 1: features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat clfsh ds acpi mmx fxsr sse sse2 ss htt tm pbe sse3 monitor dscpl est tm2
KERN: ACPI: RSDP 0x000fe020 00024 (v02 ACRSYS)
KERN: ACPI: XSDT 0x5f4fe120 00064 (v01 ACRSYS ACRPRDCT 00000001      01000013)
KERN: ACPI: FACP 0x5f4fc000 000F4 (v04 ACRSYS ACRPRDCT 00000001 1025 01000013)
KERN: ACPI: DSDT 0x5f4f2000 05DE6 (v01 ACRSYS ACRPRDCT 00000001 1025 01000013)
KERN: ACPI: FACS 0x5f488000 00040
KERN: ACPI: SSDT 0x5f4fd000 004C4 (v02  PmRef    CpuPm 00003000 INTL 20051117)
KERN: ACPI: HPET 0x5f4fb000 00038 (v01 ACRSYS ACRPRDCT 00000001 1025 01000013)
KERN: ACPI: APIC 0x5f4fa000 00068 (v02 ACRSYS ACRPRDCT 00000001 1025 01000013)
KERN: ACPI: MCFG 0x5f4f9000 0003C (v01 ACRSYS ACRPRDCT 00000001 1025 01000013)
KERN: ACPI: ASF! 0x5f4f8000 000A5 (v32 ACRSYS ACRPRDCT 00000001 1025 01000013)
KERN: ACPI: SLIC 0x5f4f1000 00176 (v01 ACRSYS ACRPRDCT 00000001 1025 01000013)
KERN: ACPI: BOOT 0x5f4f0000 00028 (v01 ACRSYS ACRPRDCT 00000001 1025 01000013)
KERN: ACPI: Executed 1 blocks of module-level executable AML code
KERN: publish device: node 0xccd260a0, path acpi/namespace, module bus_managers/acpi/namespace/device_v1
KERN: publish device: node 0x8282c2d0, path power/embedded_controller/0, module drivers/power/acpi_embedded_controller/device_v1
KERN: publish device: node 0x8282c370, path power/acpi_battery/0, module drivers/power/acpi_battery/device_v1
KERN: ACPI Error: KERN: Unknown exception code: 0xFFFFFFFF (20100121/utglobal-223)
KERN: ACPI Exception: UNKNOWN_STATUS_CODE, KERN: Returned by Handler for [EmbeddedControl]KERN:  (20100121/evregion-588)
KERN: ACPI Error (psparse-0633): Method parse/execution failed [\_SB_.BAT1.UBIF] (Node 0xccd2e794)KERN: ACPI Error: KERN: Unknown exception code: 0xFFFFFFFFKERN:  (20100121/utglobal-223)
KERN: ACPI Error (psparse-0633): Method parse/execution failed [\_SB_.BAT1._BIF] (Node 0xccd2e76c)ACPI Error: Unknown exception code: 0xFFFFFFFF (20100121/utglobal-223)

Change History (7)

comment:1 by kallisti5, 10 years ago

Summary: Battery ACPI errors on Acer Aspire One AOA150 / ZG5ACPI errors on Acer Aspire One AOA150 / ZG5

Also should be noted that with acpi on, the CPU frequency scaling preferences work! for about 1 second.. then KDL's with a general protection fault.

comment:2 by vegardw, 10 years ago

I seem to get more or less the same error messages when PowerStatus is running in the deskbar on my Aspire One AOA110. The following is printed regularly to the syslog while PowerStatus is running. If quitting PowerStatus it stops being printed to the syslog:

KERN: ACPI Error: KERN: Unknown exception code: 0xFFFFFFFFKERN:  (20100121/utglobal-223)
KERN: ACPI Exception: UNKNOWN_STATUS_CODE, KERN: Returned by Handler for [EmbeddedControl]KERN:  (20100121/evregion-588)
KERN: ACPI Error (psparse-0633): Method parse/execution failed KERN: [\_SB_.BAT1._BST] (Node 0xccd2e7bc)KERN: ACPI Error: KERN: Unknown exception code: 0xFFFFFFFFKERN:  (20100121/utglobal-223)
KERN: , UNKNOWN_STATUS_CODE

comment:3 by phoudoin, 10 years ago

I get those errors too on my Samsung NC10, so it's more ACPI errors related to our embedded_controller driver.

comment:4 by tqh, 10 years ago

Cc: fredrik.holmqvist@… added

Probably confusion between B_ERRORs and ACPI errors. First are negative, second are positive.
So it is time to fix Embedded Controller. To bad I have a busy weekend already.

comment:5 by kallisti5, 10 years ago

weird, i just tried the latest nightly (hrev35770) and this behavior has changed. The errors are gone, and a lot more battery info shows up... still missing the actual battery percentage though...

acpi battery dev node:

Battery Status:
 State 0, Current Rate -1, Capacity -1, Voltage -1

Battery Info:
 Power Unit 1, Design Capacity 7200, Last Full Charge 6961, Technology 1
 Design Voltage 11100, Design Capacity Warning 300, Design Capacity Low 278, Capacity Granularity1 32, Capacity Granularity1 32
 Model Number UM08A73, Serial Number 4E4C, Type LION, OEM Info SIMPLO

acpi syslog:

KERN: smp: using ACPI to detect MP configuration
KERN: CPU 1: features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat clfsh ds acpi mmx fxsr sse sse2 ss htt tm pbe sse3 monitor dscpl est tm2 
KERN: ACPI: RSDP 0x000fe020 00024 (v02 ACRSYS)
KERN: ACPI: XSDT 0x5f4fe120 00064 (v01 ACRSYS ACRPRDCT 00000001      01000013)
KERN: ACPI: FACP 0x5f4fc000 000F4 (v04 ACRSYS ACRPRDCT 00000001 1025 01000013)
KERN: ACPI: DSDT 0x5f4f2000 05DE6 (v01 ACRSYS ACRPRDCT 00000001 1025 01000013)
KERN: ACPI: FACS 0x5f488000 00040
KERN: ACPI: SSDT 0x5f4fd000 004C4 (v02  PmRef    CpuPm 00003000 INTL 20051117)
KERN: ACPI: HPET 0x5f4fb000 00038 (v01 ACRSYS ACRPRDCT 00000001 1025 01000013)
KERN: ACPI: APIC 0x5f4fa000 00068 (v02 ACRSYS ACRPRDCT 00000001 1025 01000013)
KERN: ACPI: MCFG 0x5f4f9000 0003C (v01 ACRSYS ACRPRDCT 00000001 1025 01000013)
KERN: ACPI: ASF! 0x5f4f8000 000A5 (v32 ACRSYS ACRPRDCT 00000001 1025 01000013)
KERN: ACPI: SLIC 0x5f4f1000 00176 (v01 ACRSYS ACRPRDCT 00000001 1025 01000013)
KERN: ACPI: BOOT 0x5f4f0000 00028 (v01 ACRSYS ACRPRDCT 00000001 1025 01000013)
KERN: ACPI: Executed 1 blocks of module-level executable AML code
KERN: publish device: node 0xccd260a0, path acpi/namespace, module bus_managers/acpi/namespace/device_v1
KERN: publish device: node 0xccd62910, path power/embedded_controller/0, module drivers/power/acpi_embedded_controller/device_v1
KERN: publish device: node 0x82828320, path power/acpi_battery/0, module drivers/power/acpi_battery/device_v1

comment:6 by kallisti5, 10 years ago

ok wait... the OEM battery shows random behavior in addition to the acpi errors above. Lets recap...

Stock battery:

battery applet does not work
acpi errors occur:

KERN: ACPI Error: KERN: Unknown exception code: 0xFFFFFFFFKERN:  (20100121/utglobal-223)
KERN: ACPI Exception: UNKNOWN_STATUS_CODE, KERN: Returned by Handler for [EmbeddedControl]KERN:  (20100121/evregion-588)
KERN: ACPI Error (psparse-0633): Method parse/execution failed KERN: [\_SB_.BAT1._BST] (Node 0xccd2e7bc)KERN: ACPI Error: KERN: Unknown exception code: 0xFFFFFFFFKERN:  (20100121/utglobal-223)
KERN: , UNKNOWN_STATUS_CODE


Battery info DOES show up randomly in dev power acpi node:

Battery Status:

 State 1, Current Rate 1110, Capacity 608, Voltage 10494

Battery Info:
 Power Unit 1, Design Capacity 2200, Last Full Charge 1900, Technology 1
 Design Voltage 10800, Design Capacity Warning 300, Design Capacity Low 76, Capacity Granularity1 32, Capacity Granularity1 32
 Model Number UM08A31, Serial Number 0A11, Type LION, OEM Info SANYO


5 seconds later:

Battery Status:
 State -2105022076, Current Rate 582, Capacity -2104913240, Voltage -2104913240

Battery Info:
 Power Unit 1, Design Capacity 2200, Last Full Charge 1900, Technology 1
 Design Voltage 10800, Design Capacity Warning 300, Design Capacity Low 76, Capacity Granularity1 32, Capacity Granularity1 32
 Model Number UM08A31, Serial Number 0A11, Type LION, OEM Info SANYO

Extended 3rd party battery:

battery applet DOES work.
no ACPI errors like before:

KERN: smp: using ACPI to detect MP configuration
KERN: CPU 1: features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat clfsh ds acpi mmx fxsr sse sse2 ss htt tm pbe sse3 monitor dscpl est tm2 
KERN: ACPI: RSDP 0x000fe020 00024 (v02 ACRSYS)
KERN: ACPI: XSDT 0x5f4fe120 00064 (v01 ACRSYS ACRPRDCT 00000001      01000013)
KERN: ACPI: FACP 0x5f4fc000 000F4 (v04 ACRSYS ACRPRDCT 00000001 1025 01000013)
KERN: ACPI: DSDT 0x5f4f2000 05DE6 (v01 ACRSYS ACRPRDCT 00000001 1025 01000013)
KERN: ACPI: FACS 0x5f488000 00040
KERN: ACPI: SSDT 0x5f4fd000 004C4 (v02  PmRef    CpuPm 00003000 INTL 20051117)
KERN: ACPI: HPET 0x5f4fb000 00038 (v01 ACRSYS ACRPRDCT 00000001 1025 01000013)
KERN: ACPI: APIC 0x5f4fa000 00068 (v02 ACRSYS ACRPRDCT 00000001 1025 01000013)
KERN: ACPI: MCFG 0x5f4f9000 0003C (v01 ACRSYS ACRPRDCT 00000001 1025 01000013)
KERN: ACPI: ASF! 0x5f4f8000 000A5 (v32 ACRSYS ACRPRDCT 00000001 1025 01000013)
KERN: ACPI: SLIC 0x5f4f1000 00176 (v01 ACRSYS ACRPRDCT 00000001 1025 01000013)
KERN: ACPI: BOOT 0x5f4f0000 00028 (v01 ACRSYS ACRPRDCT 00000001 1025 01000013)
KERN: ACPI: Executed 1 blocks of module-level executable AML code
KERN: publish device: node 0xccd260a0, path acpi/namespace, module bus_managers/acpi/namespace/device_v1
KERN: publish device: node 0xccd62910, path power/embedded_controller/0, module drivers/power/acpi_embedded_controller/device_v1
KERN: publish device: node 0x82828320, path power/acpi_battery/0, module drivers/power/acpi_battery/device_v1


battery info does seem to show up consistently, but with some values missing:


Battery Status:
 State 0, Current Rate -1, Capacity -1, Voltage -1

Battery Info:
 Power Unit 1, Design Capacity 7200, Last Full Charge 6961, Technology 1
 Design Voltage 11100, Design Capacity Warning 300, Design Capacity Low 278, Capacity Granularity1 32, Capacity Granularity1 32
 Model Number UM08A73, Serial Number 4E4C, Type LION, OEM Info SIMPLO

comment:7 by tqh, 9 years ago

Resolution: duplicate
Status: newclosed

This is a duplicate of #4623.

Note: See TracTickets for help on using tickets.