Opened 9 years ago

Closed 4 months ago

#5532 closed bug (fixed)

Complete system freeze when using atheroswifi with an SMP system.

Reported by: jstressman Owned by: colin
Priority: normal Milestone: R1
Component: Drivers/Network/atheroswifi Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I was getting a number of complete system locks while trying to install the BeZillaBrowser package, or just in general after a variable amount of time (sometimes immediately when reaching the desktop, or maybe after 10 minutes etc).

So I began testing and removed the atheroswifi driver. This "fixed the problem" and I ran the computer for about an hour with no problems. So then I restored the driver and did some research into whether or not anyone had had any problems with the BSD drivers themselves, where I found that this seemed to be a known LOR (lock order reversal) problem and the email recommended to disable SMP as a workaround until the problem was fixed.

http://unix.derkeiler.com/Mailing-Lists/FreeBSD/current/2009-10/msg00495.html

So I disabled SMP and was able to surf the net, chat, etc... for 17 hours with no problems before I rebooted the system myself.

I re-enabled SMP for testing a bit ago and was able to freeze the system completely within less than 2 minutes of using the internet.

This is a hard freeze where the system instantly becomes completely unresponsive. No keyboard shortcuts work etc. (No alt+sysreq+d for KDL, no ctrl+alt+del etc) You have to press the power button on the computer itself to shut off the machine.

Here are some of the other links I was looking at that may be related:

http://sources.zabbadoz.net/freebsd/lor.html

http://sources.zabbadoz.net/freebsd/lor/42.html http://sources.zabbadoz.net/freebsd/lor/224.html http://sources.zabbadoz.net/freebsd/lor/170.html http://sources.zabbadoz.net/freebsd/lor/59.html

I'm also attaching the output of listdev, and a few copies of the syslog from before the crash.

(this is nightly build hrev35693 gcc4hybrid)

Attachments (4)

listdev2.txt (5.5 KB) - added by jstressman 9 years ago.
output of 'listdev'
syslog2.txt (293.2 KB) - added by jstressman 9 years ago.
first output of syslog
syslog3.txt (448.3 KB) - added by jstressman 9 years ago.
later output of syslog before the crash
syslog6b.txt (146.9 KB) - added by jstressman 9 years ago.
updated syslog output after upgrading to hrev35752 and finding even worse driver issues.

Download all attachments as: .zip

Change History (17)

Changed 9 years ago by jstressman

Attachment: listdev2.txt added

output of 'listdev'

Changed 9 years ago by jstressman

Attachment: syslog2.txt added

first output of syslog

Changed 9 years ago by jstressman

Attachment: syslog3.txt added

later output of syslog before the crash

comment:1 Changed 9 years ago by stippi

Thanks a lot for doing all the research! That's very helpful. If you notice that the problem is fixed upstream, and we have not updated the driver, be sure to leave a note!

comment:2 Changed 9 years ago by colin

Owner: changed from nobody to colin
Status: newin-progress

Hey, thanks for this detailed bug report, great work :) I have to wishes, though. I've updated the atheros wifi driver to the latest version in FreeBSD. Can you give it a try and report back whether it still crashes (reporting back is the second wish ;)

Changed 9 years ago by jstressman

Attachment: syslog6b.txt added

updated syslog output after upgrading to hrev35752 and finding even worse driver issues.

comment:3 Changed 9 years ago by jstressman

Well, bad news and more bad news. :/

First, the bug is still there.

I updated to the latest nightly, then rebooted (warm). It totally locked at the desktop before the tracker even loaded. So I cold booted and got the desktop loaded... and then I managed to hard lock the system as soon as I browsed to gmail in WebPositive and before I could even log in.

Second; I cold booted again and disabled SMP... and got to the desktop fine... but the network appears even worse now. While it doesn't hard lock the system, it appears to constantly disconnect and reconnect thinking there's a media change. So I couldn't really load web pages, and Vision silently dropped my connection almost immediately.

I'm including an updated syslog (syslog6b.txt) with all the new messages. You'll notice they weren't there before in the earlier syslogs before the latest wifi drivers update. (between hrev35693 and hrev35752)

comment:4 Changed 9 years ago by jstressman

Component: - GeneralNetwork & Internet/Wireless

(just updating the component info to make it easier to find)

comment:5 Changed 9 years ago by gluon

Just to add some info I've been experiencing this bug too and I've decided to check the latest revision from the FreeBSD SVN repo. I've noticed some commits referring to fixes to the hang/disconnect issues. I've tried to compile the latest sources but I'm getting some linking errors probably related to glue.o. I believe some progress has been made upstream so maybe importing the latest versions into Haiku would help.

comment:6 Changed 7 years ago by diver

Component: Network & Internet/WirelessDrivers/Network/aironetwifi

Do you still have this issue?

comment:7 Changed 7 years ago by jstressman

I'm using a wired connection on this machine now, but the card is still in it. I haven't been able to get it to properly connect though to test and see if actually using that connection causes a lock-up.

But as far as simply having the driver loaded I haven't had any issues with it.

I'll have to try to get it working to test if actually using the connection causes any problems.

comment:8 Changed 7 years ago by tqh

Given the huge amount written in syslog it would be very interesting to see what happens after hrev44350.

comment:9 Changed 7 years ago by jstressman

I'll update when the next nightly build comes out and test it then.

comment:10 Changed 10 months ago by waddlesplash

Still an issue?

comment:11 Changed 10 months ago by waddlesplash

Component: Drivers/Network/aironetwifiDrivers/Network/atheroswifi
Keywords: atheroswifi atheros smp removed

comment:12 Changed 10 months ago by waddlesplash

Please retest after hrev52093. FreeBSD had a lot of SMP fixes in 10.0+, so this may well be fixed.

comment:13 Changed 4 months ago by waddlesplash

Resolution: fixed
Status: in-progressclosed

Similar tickets were reported as fixed, and no reply here; so closing as fixed.

Note: See TracTickets for help on using tickets.