Opened 10 years ago

Closed 10 years ago

#5537 closed bug (fixed)

ACPI: PowerStatus sometimes shows battery 0%

Reported by: vegardw Owned by: tqh
Priority: normal Milestone: R1
Component: Drivers/ACPI Version: R1/Development
Keywords: Cc: fredrik.holmqvist@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is on my Acer Aspire One. ACPI is enabled.

PowerStatus did show the correct battery level on hrev35727, but always shows 0% on hrev35761.

It says "Battery unused" and "Capacity" and "Current rate" is listed as -1 mAh / -1 mA in the Extended battery info window. Both values showed other numbers in hrev35727.

Attached is syslog and screenshot of Extended battery info window

Attachments (2)

syslog_powerstatus_0.txt (98.2 KB ) - added by vegardw 10 years ago.
screenshot_powerstatus_0.png (104.9 KB ) - added by vegardw 10 years ago.

Download all attachments as: .zip

Change History (11)

by vegardw, 10 years ago

Attachment: syslog_powerstatus_0.txt added

by vegardw, 10 years ago

comment:1 by vegardw, 10 years ago

Summary: ACPI: PowerStatus shows battery 0%ACPI: PowerStatus sometimes shows battery 0%

Doesn't seem to have anything to do with hrev35727 vs hrev35761. I tried enabling apm as well as acpi in /boot/home/config/settings/kernel/drivers/kernel as I seemed to remember that I had both enabled in hrev35727.

And with both "apm true" and "acpi true" the battery status was shown correctly. I then disabled apm again and rebooted, and PowerStatus showed 100%. I then rebooted once again, and it was back to 0% Trying to reboot more times after that, and it still showed 0%. I then tried enabling apm again, and the same thing happened: The battery status is shown correctly when both acpi and apm are enabled, and the first boot after disabling apm, but keeping acpi.

Could it be a PowerStatus issue instead of an acpi issue?

comment:2 by tqh, 10 years ago

This might be a duplicate of #5244 and #4623 but need to look into it. Also I should probably fix that now that I have gotten the hang of ACPI.

comment:3 by tqh, 10 years ago

Cc: fredrik.holmqvist@… added

comment:4 by mmlr, 10 years ago

Just to make sure: Did it occur to you that it might simply be using APM to get that battery info? PowerStatus also has an APM backend. From what you wrote it looks to me like it always works when APM is enabled, so...

comment:5 by vegardw, 10 years ago

Doesn't look like it is using APM. With only APM enabled, PowerStatus won't run at all. When I run it in a terminal with only APM enabled, the following is printed, and PowerStatus exits without showing the window at all:

~> PowerStatus 
ACPI connect
No power interface found.

When the battery level is shown correctly, the following is printed and the window is shown:

~> PowerStatus 
ACPI connect
try /dev/power/acpi_battery/0
ACPI driver found

Also, when only ACPI is enabled and the battery is shown as 0%, last full charge etc is displayed correctly, som I'm pretty sure it's ACPI that's used.

comment:6 by axeld, 10 years ago

Owner: changed from nobody to tqh
Status: newassigned

Please retest with hrev36511 or newer.

comment:7 by jackburton, 10 years ago

I had a similar problem, works fine after hrev36511.

in reply to:  6 comment:8 by vegardw, 10 years ago

Replying to axeld:

Please retest with hrev36511 or newer.

Yep, fixed in hrev36511. Tested on hrev36511 and hrev36537. Unable to reproduce on either.

comment:9 by tqh, 10 years ago

Resolution: fixed
Status: assignedclosed

Thanks.

Note: See TracTickets for help on using tickets.