Opened 10 years ago

Closed 10 years ago

#5545 closed bug (invalid)

bcm4312 wlan (on Dell Mini 10) not detected

Reported by: danboid Owned by: colin
Priority: normal Milestone: R1/alpha2
Component: Drivers/Network Version: R1/Development
Keywords: bcm4312 dell mini 10 wifi Cc:
Blocked By: Blocking: #6146
Has a Patch: no Platform: x86

Description

I'm running hrev35770 gcc2hybrid raw, booting off a USB stick on a Dell Mini10 (or the Inspiron 1010 as its called here in UK). According to Colin's blog, the recent Haiku nightlies should have support for the bcm4312, at least for connecting to unencrypted wifi networks; but my wlan chipset isn't listed under the Haiku network tool nor by ifconfig.

Attachments (2)

mini10-psb.txt (1.9 KB ) - added by danboid 10 years ago.
Dell Mini 10 device list
syslog (474.6 KB ) - added by danboid 10 years ago.
Dell Mini 10 syslog

Download all attachments as: .zip

Change History (5)

by danboid, 10 years ago

Attachment: mini10-psb.txt added

Dell Mini 10 device list

by danboid, 10 years ago

Attachment: syslog added

Dell Mini 10 syslog

comment:1 by anevilyak, 10 years ago

Owner: changed from nobody to colin
Status: newassigned

comment:2 by colin, 10 years ago

Resolution: invalid
Status: assignedclosed

First thx for the report. The bad news: It's no bug. The driver simply doesn't support the device in the Dell Mini 10. Syslog says it has deviceid 4315, which isn't listed as a supported device.
It would require a newer version called bwn (we are using bwi), which is still in development by the FreeBSD people.

comment:3 by luroh, 9 years ago

Blocking: 6146 added

(In #6146) Closing as duplicate of #5545.

Note: See TracTickets for help on using tickets.