Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6146 closed bug (duplicate)

wifi card BCM4312 not visible

Reported by: Oxy-2 Owned by: nobody
Priority: normal Milestone: R1
Component: Drivers/Network Version: R1/alpha2
Keywords: Cc:
Blocked By: #5545 Blocking:
Has a Patch: no Platform: x86

Description

netbook HP mini 210-1031. wifi card Broadcom BCM4312 is not determined by driver broadcom43xx.

listdev: device Network controller [2|80|0]

vendor 14e4: Broadcom Corporation device 4315: BCM4312 802.11b/g LP-PHY

Attachments (3)

syslog (84.2 KB ) - added by Oxy-2 10 years ago.
syslog. clean…
listdev (2.3 KB ) - added by Oxy-2 10 years ago.
syslog.2 (75.1 KB ) - added by Oxy-2 10 years ago.
syslog after editing if_bwi_pci.c

Download all attachments as: .zip

Change History (10)

comment:1 by Oxy-2, 10 years ago

continue. I tried to correct a driver code. Has added string

{ PCI_VENDOR_BROADCOM, 0x4315,"Broadcom BCM4315 802.11b/g Wireless Lan" }

in if_bwi_pci.c. The device was defined, but not initialized.

KERN: vesa: acc: vesa.accelerant
KERN: broadcom43xx: init_driver(0x81287250)
KERN: [broadcom43xx] (bwi) bus_alloc_resource(3, [16], 0x0, 0xffffffff, 0x1,0x2)
KERN: add_memory_type_range(1625, 0x96000000, 0x20000, 0)
KERN: set MTRRs to:
KERN:   mtrr:  0: base: 0x7dbd5000, size:     0x1000, type: 0
KERN:   mtrr:  1: base: 0x7dbd6000, size:     0x2000, type: 0
KERN:   mtrr:  2: base: 0x7dbd8000, size:     0x8000, type: 0
KERN:   mtrr:  3: base: 0x90000000, size: 0x10000000, type: 0
KERN:   mtrr:  4: base: 0x80000000, size: 0x80000000, type: 1
KERN: update_mtrrs(): Succeeded setting MTRRs after ignoring uncacheable ranges up to size 0x1000.
KERN: [broadcom43xx] (bwi) bus_alloc_resource(1, [0], 0x0, 0xffffffff, 0x1,0x6)
KERN: [broadcom43xx] (bwi) BBP: id 0x4312, rev 0x1, pkg 0
KERN: [broadcom43xx] (bwi) MAC rev KERN: 15 is not supported
KERN: [broadcom43xx] (bwi) no MAC was found
KERN: remove_memory_type_range(1625, 0x96000000, 0x20000, 0)
KERN: set MTRRs to:
KERN:   mtrr:  0: base: 0x7dbd5000, size:     0x1000, type: 0
KERN:   mtrr:  1: base: 0x7dbd6000, size:     0x2000, type: 0
KERN:   mtrr:  2: base: 0x7dbd8000, size:     0x8000, type: 0
KERN:   mtrr:  3: base: 0x90000000, size: 0x10000000, type: 0
KERN:   mtrr:  4: base: 0x80000000, size: 0x80000000, type: 1
KERN: update_mtrrs(): Succeeded setting MTRRs after ignoring uncacheable ranges up to size 0x1000.
KERN: etherpci: init_driver init_driver: etherpci not found 

comment:2 by anevilyak, 10 years ago

That would appear to imply that the driver doesn't currently know how to deal with your particular chipset unfortunately.

in reply to:  2 comment:3 by Oxy-2, 10 years ago

I hope it will teach :)

comment:4 by Oxy-2, 10 years ago

Windows shows PCI\VEN_14E4&DEV_4315&SUBSYS_365E103C&REV_01

by Oxy-2, 10 years ago

Attachment: syslog added

syslog. clean...

by Oxy-2, 10 years ago

Attachment: listdev added

by Oxy-2, 10 years ago

Attachment: syslog.2 added

syslog after editing if_bwi_pci.c

comment:5 by Oxy-2, 10 years ago

revered thread about bwi in freebsd ... outcome - = Type 5 is LP phy chip which is not supported ... bwi not work with 0x4315 =

comment:6 by luroh, 10 years ago

Blocked By: 5545 added
Resolution: duplicate
Status: newclosed

Closing as duplicate of #5545.

comment:7 by Oxy-2, 10 years ago

sorry, did not notice 5545.

Note: See TracTickets for help on using tickets.