Opened 9 years ago

Closed 9 years ago

#5569 closed bug (duplicate)

iprowifi3945 driver completely hangs the system

Reported by: jackburton Owned by: colin
Priority: normal Milestone: R1
Component: Drivers/Network Version: R1/Development
Keywords: gcc4 hybrid Cc:
Blocked By: #5511 Blocking:
Has a Patch: no Platform: x86

Description (last modified by jackburton)

Since some revisions, Haiku hangs at boot on my machine, unless I remove that driver. The system is so hanged that it won't enter KDL.

Attachments (2)

syslog.txt (18.4 KB) - added by jackburton 9 years ago.
CIMG1887.JPG (371.4 KB) - added by jackburton 9 years ago.
"ints" KDL command, without wireless. I remember wireless gets mapped at irq 10

Download all attachments as: .zip

Change History (11)

comment:1 Changed 9 years ago by jackburton

As I suspected: I removed the network drivers, and added back one by one with net_server running. As soon as I add the iprowifi3945, the system hangs. Syslog follows.

Changed 9 years ago by jackburton

Attachment: syslog.txt added

comment:2 Changed 9 years ago by bonefish

"Since some revisions" could mean since the WLAN drivers were added to the image. You could try to boot with those disabled/removed.

Unless you have already done that, you should wait a while (maybe one or two minutes) after the hang. If it's some spinlock deadlock/double lock, the system should panic after a while.

Finally, in case not all of the syslog is written to disk, you could "Enable debug syslog" in the boot loader and reenter the boot loader after resetting machine after the hang and "Display syslog from previous session" (both in the "Select debug options" submenu).

comment:3 in reply to:  2 Changed 9 years ago by bonefish

Owner: changed from nobody to colin
Status: newassigned

Replying to bonefish:

"Since some revisions" could mean since the WLAN drivers were added to the image. You could try to boot with those disabled/removed.

Oh, sorry, I overlooked your first comment.

comment:4 Changed 9 years ago by axeld

It's likely to be an interrupt storm. You could have a look at the "ints" KDL command.

For example, I had this problem on my laptop after having installed openSUSE - the machine would randomly assign IRQs to the ethernet and wireless cards.

comment:5 in reply to:  4 Changed 9 years ago by jackburton

Replying to axeld:

It's likely to be an interrupt storm. You could have a look at the "ints" KDL command.

I would, if I could enter KDL :-)

For example, I had this problem on my laptop after having installed openSUSE - the machine would randomly assign IRQs to the ethernet and wireless cards.

Last week, when I opened ticket #5548, I tried the ints KDL command, and I remember the wireless card was sharing IRQ with at least 4 or 5 other devices.

Changed 9 years ago by jackburton

Attachment: CIMG1887.JPG added

"ints" KDL command, without wireless. I remember wireless gets mapped at irq 10

comment:6 Changed 9 years ago by jackburton

I added a picture which shows (besides that the screen of my laptop needs cleaning) the output of "ints" KDL command, after having removed the offending driver (since with it, I can't even enter KDL).

comment:7 Changed 9 years ago by jackburton

Description: modified (diff)
Summary: Net_server completely hangs the systemiprowifi3945 driver completely hangs the system

comment:8 Changed 9 years ago by colin

Status: assignedin-progress

Looks like a duplicate of ticket #5511. Even though you aren't reporting interrupt storms, the syslog says "timeout waiting for adapter to initialize" which means that irqs are misrouted. Though as ticket #5511 presents no real solution (which would be implementing acpi irq routing) it contains a work around. If you are running a linux on your machine and retrieve the needed info with it we can, at least, make it work for you.

comment:9 in reply to:  8 Changed 9 years ago by jackburton

Blocked By: 5511 added
Resolution: duplicate
Status: in-progressclosed

Replying to colin:

Looks like a duplicate of ticket #5511. Even though you aren't reporting interrupt storms, the syslog says "timeout waiting for adapter to initialize" which means that irqs are misrouted. Though as ticket #5511 presents no real solution (which would be implementing acpi irq routing) it contains a work around. If you are running a linux on your machine and retrieve the needed info with it we can, at least, make it work for you.

Thanks. It's not really a problem at the moment, since to be able to use the wireless network I need WPA2 support. For the moment I can just remove the driver, hoping that someone implements ACPI routing soon. Let's close this as dup of #5511 then.

Note: See TracTickets for help on using tickets.