Opened 9 years ago

Closed 4 years ago

#5580 closed bug (fixed)

Audio CD plays interruptably

Reported by: libcha Owned by: bga
Priority: normal Milestone: R1
Component: File Systems/cdda Version: R1/alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When playing audioCD with MediaPlayer, it lasts long time to start playing (see #4222). But when playing, it plays only few seconds sound, then freezes for next few second and than plays again... By me it's caused by stopping the CD after each attempt, so it needs init then to read next data.

CD-RW/DVD drive Samsung SM-352 IDE onboard audio card Realtek (motherboard MSI 915GLM-V)

Change History (4)

comment:1 Changed 9 years ago by anevilyak

Component: - GeneralApplications/MediaPlayer
Owner: changed from nobody to stippi

comment:2 Changed 9 years ago by stippi

Component: Applications/MediaPlayerFile Systems/cdda
Owner: changed from stippi to bga

I don't believe this has anything to do with the MediaPlayer. Rather the CDDA FS.

comment:3 Changed 9 years ago by axeld

The long delay is definitely the fault of our WAV codec, but I guess stippi could be right about the stuttering.

comment:4 Changed 4 years ago by waddlesplash

Resolution: fixed
Status: newclosed

I haven't ever had this happen, on real hardware (really old AMD Athlon XP too) or in VBox. Assuming fixed (we now use FFmpeg for decoding...)

Note: See TracTickets for help on using tickets.