Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#559 closed bug (fixed)

App freeze or crash when Tab pressed

Reported by: g.zachrisson@… Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

If the Tab key is pressed in Workspaces, the application is crashing, and if the Tab key is pressed in Pulse or AboutHaiku, then the apps can not be closed by clicking the window close button.

I'll attached a stack trace from the Workspaces crash.

Test setup: Haiku partition with rev17274.

Attachments (3)

BT_of_Workspaces_crashed_when_Alt-Tab.png (77.7 KB) - added by g.zachrisson@… 13 years ago.
Stack trace of Workspaces crash
Window.cpp (67.4 KB) - added by g.zachrisson@… 13 years ago.
patched Window.cpp
Window.2.cpp (67.6 KB) - added by g.zachrisson@… 13 years ago.
UPDATED patched Window.cpp

Download all attachments as: .zip

Change History (10)

comment:1 Changed 13 years ago by g.zachrisson@…

op_sys: AllHaiku

Changed 13 years ago by g.zachrisson@…

Stack trace of Workspaces crash

comment:2 Changed 13 years ago by g.zachrisson@…

I have found the root cause and also created and tested a solution. Will add a patch shortly.

comment:3 Changed 13 years ago by g.zachrisson@…

Axel, could you please check in the attached patch, since I have no rights to do that? All the changes are in BWindow::_FindNextNavigable().

comment:4 Changed 13 years ago by g.zachrisson@…

Hang on a second, I forgot to add a fix for SHIFT+TAB. I've just created that in BWindow::_FindPreviousNavigable(), and I will submit an updated patch when I've tested that the new patch is working.

Changed 13 years ago by g.zachrisson@…

Attachment: Window.cpp added

patched Window.cpp

comment:5 Changed 13 years ago by axeld

Resolution: fixed

comment:6 Changed 13 years ago by axeld

Status: newclosed

comment:7 Changed 13 years ago by axeld

Fixed in hrev17287. Thanks for the patch! Next time, it would be nice if you could only do a real patch (ie. using diff) instead of adding the patched version, though.

I took the liberty of editing your patch a bit; I also didn't apply the one to _FindPreviousNavigable() as this method was completely broken.

Changed 13 years ago by g.zachrisson@…

Attachment: Window.2.cpp added

UPDATED patched Window.cpp

Note: See TracTickets for help on using tickets.