Opened 9 years ago

Closed 8 years ago

#5594 closed bug (fixed)

A few strings are missing in DriveSetup locale catalog

Reported by: koki Owned by: axeld
Priority: normal Milestone: Unscheduled
Component: File Systems/BFS Version: R1/Development
Keywords: catalog Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The following strings used in the initialization parameters window (Partition > Initialize > Be File System... > Continue) seem to be missing from the DriveSetup locale catalog:

  • Name:
  • Blocksize:
  • Enable query support
  • (Recommended)
  • (Mostly small files)
  • (Mostly large files)

Attachments (1)

syslog-drivesetup (3.8 KB ) - added by humdinger 9 years ago.
Syslog output when initializing a partition in DriveSetup

Download all attachments as: .zip

Change History (11)

comment:1 by idefix, 9 years ago

Component: Applications/MailFile Systems/BFS
Owner: changed from bga to axeld

That's because they are not part of DriveSetup, but part of the BFS-addon (specifically: InitializeParameterEditor.cpp).

in reply to:  1 comment:2 by koki, 9 years ago

Replying to idefix:

That's because they are not part of DriveSetup, but part of the BFS-addon (specifically: InitializeParameterEditor.cpp).

I see. In that case, feel free to change the description (I don't have enough permissions). Or should I open a separate ticket for the localization of the add-on?

comment:3 by idefix, 9 years ago

Implemented in changeset:40442.

comment:4 by korli, 9 years ago

Resolution: fixed
Status: newclosed

Thanks for the notice idefix!

comment:5 by humdinger, 9 years ago

Resolution: fixed
Status: closedreopened

Unfortunately, it's not yet completely fixed...
The AddOns (here and here) now have catalogs which even made it to HTA and at least the German translation is in SVN. But still, those strings don't appear in the DriveSetup app.

What's missing? Some Jamfile issue?

comment:6 by pulkomandy, 9 years ago

You can compile the locale kit with debug enabled (SetconfigVar DEBUG ...) and see messages in the syslog about what it's doing.

comment:7 by humdinger, 9 years ago

OK, finally got around to make a debug build. The syslog said the MIME type was missing. With hrev40585 the add-ons finally got their MIME type, but it still doesn't find the catalogs, see attached syslog snippet. Ideas?

by humdinger, 9 years ago

Attachment: syslog-drivesetup added

Syslog output when initializing a partition in DriveSetup

comment:8 by siarzhuk, 8 years ago

Please check revisions after hrev40734.

PS: Isn't the #7293 duplicate of this?

comment:9 by diver, 8 years ago

Confirmed, please close.

in reply to:  9 comment:10 by siarzhuk, 8 years ago

Resolution: fixed
Status: reopenedclosed

Replying to diver:

Confirmed, please close.

OK. Thanks.

Note: See TracTickets for help on using tickets.