Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#56 closed bug (fixed)

Sound is distorted

Reported by: fekdahl@… Owned by: korli
Priority: normal Milestone: R1
Component: System/Kernel Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

It gets worse with higher volumes. The same applies to the driver bundled with R5. Using a SoundBlaster Live! Player 1024 card (IIRC). Using the digital output, but the sound is distorted on the analog outputs too. In Windows there is no such problem, so the problem can't be in the hardware. I'm also using Haiku media kit.

Change History (4)

comment:1 Changed 13 years ago by fekdahl@…

The issue is resolved. It turned out to be a problem with IRQ sharing; sound and USB had the same IRQ. After moving around the sound card until it got its own IRQ, sound is perfect!

Sorry for bothering

/Fredrik Ekdahl

comment:2 Changed 13 years ago by fekdahl@…

Resolution: fixed

comment:3 Changed 13 years ago by fekdahl@…

Status: newclosed

comment:4 Changed 13 years ago by korli

Do you know if it was better without usb drivers installed ? They could be misbehaving and thus be culprit (no usb yet, so sound should be ok in Haiku)

Note: See TracTickets for help on using tickets.