Opened 10 years ago

Closed 7 years ago

#5665 closed bug (fixed)

Boot loader docs show Select safe mode options wrong

Reported by: richienyhus Owned by: nielx
Priority: low Milestone: Unscheduled
Component: Website Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Two options are shown on the same line:

  • - Safe mode
  • - Disable user add-ons
  • - Disable IDE DMA
  • - Use fail-safe video mode
  • - Don't call the BIOS
  • - Disable APM
  • - Disable ACPI
  • - Disable IO-APIC
  • - Enable serial debug output - Enable on screen debug output

Change History (13)

comment:1 by humdinger, 10 years ago

Resolution: fixed
Status: newclosed

comment:2 by richienyhus, 10 years ago

Resolution: fixed
Status: closedreopened

doh, I should of pointed out where is was hosted, sorry humdinger.

http://www.haiku-os.org/docs/userguide/en/bootloader.html

Is this a haiku-web problem rather than haiku-docs problem, as the website version userguide hasn't been updated?

comment:3 by humdinger, 10 years ago

Yep. It's more a website problem. I don't think there's a mechanism yet that pulls the user guide directly from SVN. Maybe the link to the user guide should simply point (or redirect) to the SVN browser page http://dev.haiku-os.org/export/36017/haiku/trunk/docs/userguide/en/contents.html.

comment:4 by richienyhus, 10 years ago

Component: DocumentationWebsite

Yep. It's more a website problem. I don't think there's a mechanism yet that pulls the user guide directly from SVN. Maybe the link to the user guide should simply point (or redirect) to the SVN browser page.

I'll change the component from docs to website in that case, so hopefully the right people see it and and can fix it or sync it.

comment:5 by koki, 10 years ago

The User Guide under the website domain is meant to be (by design) a snapshot of the document for the alpha 1 release, and what you see on SVN is the latest trunk version for people using bleeding edge builds.

In order to cater to both people using alpha 1 and nightly builds, the website should have links to both versions of the document IMO.

comment:6 by humdinger, 10 years ago

I see the need to have a fixed userguide for every release so nobody gets confused when new or changed features are described. However, IMO this should only apply to regular Rx releases, not to pre-R1 alphas. The described system components haven't changed dramatically since R1/alpha1 and users would benefit from corrections and, maybe more importantly, the now available translations.
So, if not doing automatic syncing to the SVN, maybe a manual sync could be triggered from time to time. If you agree, announce bit ahead of time, so I can do another export from the translation site first.

comment:7 by nielx, 10 years ago

Help refresh my memory: did we resolve the issue with the stylesheet in SVN being outside of the docs dir?

Also, shout when you have synced: I will update it.

in reply to:  7 comment:8 by mmadia, 10 years ago

Replying to nielx:

Help refresh my memory: did we resolve the issue with the stylesheet in SVN being outside of the docs dir?

Haiku-doc.css is indeed in docs/userguide/Haiku-doc.css and docs/welcome/Haiku-doc.css

comment:9 by humdinger, 10 years ago

I just synced the translation site stuff with svn. Feel free to update the website's guide.
WRT this ticket, the bootloader recently grew some new options. I'll add those... er... real soon now...

comment:10 by nielx, 10 years ago

Updated manually now. Keeping the ticket open until I have an automated sync.

comment:11 by nielx, 7 years ago

@humdinger

Time for a refresh of the boot loader options?

N>

comment:12 by humdinger, 7 years ago

Done. The boot loader options are again up-to-date. Maybe we should close this ticket and you track the automated sync in a new ticket?

in reply to:  12 comment:13 by nielx, 7 years ago

Resolution: fixed
Status: reopenedclosed

Replying to humdinger:

Done. The boot loader options are again up-to-date. Maybe we should close this ticket and you track the automated sync in a new ticket?

Let's use #8078 for that, though I have no real urge to work on automatic synchronization until the translation of the userguide has moved to Pootle too.

N>

Note: See TracTickets for help on using tickets.