Opened 13 years ago

Closed 12 years ago

#571 closed bug (fixed)

[StyledEdit] possible to scroll below end of file

Reported by: johndrinkwater Owned by: jackburton
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/pre-alpha1
Keywords: Cc: diver
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by jackburton)

open a long file, scroll to the bottom of the file, and resize the window to be larger. Area beyond the end of TextView doesnt invalidate (lots of resizing artifacts are left) until the user forces redraw in the usual method - another window/offscreen/minimizing. It shows up only if word wrapping is enabled.

Change History (7)

comment:1 Changed 13 years ago by leavengood

I could not reproduce this on R5. Is this possibly only a Haiku issue? If so it might be a bug in the Haiku TextView since the R5 one seems to work fine.

comment:2 Changed 13 years ago by diver

Cc: diver added

comment:3 Changed 13 years ago by axeld

Description: modified (diff)
Owner: changed from sikosis to jackburton
Platform: All

comment:4 Changed 12 years ago by jackburton

Status: newassigned

The real problem is that the window is not updated. Looks like the implementation of BTextView::SetTextRect is not sufficient. I'll take care of it.

comment:5 Changed 12 years ago by jackburton

Component: ApplicationsUser Interface/Interface Kit
Version: R1 development

comment:6 Changed 12 years ago by jackburton

Description: modified (diff)

comment:7 Changed 12 years ago by jackburton

Resolution: fixed
Status: assignedclosed

Fixed in hrev19824.

Note: See TracTickets for help on using tickets.