Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5774 closed bug (fixed)

[Tracker] EditBox shown to edit default "New folder" is at the wrong place after using Alt+N

Reported by: oco Owned by: anevilyak
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #5842
Has a Patch: no Platform: All

Description

Steps to reproduce :

  • Alt+N to create a new directory in a view with at least another one directory. The existing directory name should be before "New folder" in the alphabetical order to reproduce.

A new folder is created with the name "New folder" but the corresponding EditBox is shown on top of an existing entry instead of the "New folder" one. You can see previous item if you delete the text in the EditBox.

There is no problem if the view only contain files.

Attachments (1)

Alt+N (24.3 KB ) - added by oco 9 years ago.

Download all attachments as: .zip

Change History (6)

by oco, 9 years ago

Attachment: Alt+N added

comment:1 by oco, 9 years ago

Summary: EditBox shown to edit default "New folder" is at the wrong place after using Alt+N[Tracker] EditBox shown to edit default "New folder" is at the wrong place after using Alt+N

comment:2 by anevilyak, 9 years ago

Owner: changed from axeld to anevilyak
Status: newin-progress
Version: R1/alpha1R1/Development

Looking into it.

comment:3 by anevilyak, 9 years ago

Resolution: fixed
Status: in-progressclosed

Fixed in hrev36408.

comment:4 by anevilyak, 9 years ago

As a note this problem was also observable with only files. However, the "List Folders First" option had to be disabled for that to occur, since otherwise the folder would implicitly wind up at index 0 regardless of its name, thus masking the problem.

comment:5 by anevilyak, 9 years ago

Blocking: 5842 added

(In #5842) Duplicate of #5774, this has already been fixed in newer revisions. As for deleting attachments, those have to be done one at a time as far as I know.

Note: See TracTickets for help on using tickets.