Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#5780 closed bug (duplicate)

Dragging newly created files on Desktop crashes Tracker

Reported by: humdinger Owned by: anevilyak
Priority: blocker Milestone: R1/alpha2
Component: Applications/Tracker Version: R1/Development
Keywords: Cc:
Blocked By: #4322 Blocking:
Has a Patch: no Platform: All

Description

This is hrev36330.

I thought these backtraces were already filed in a ticket, but I couldn't find them...

To repoduce:

  • Open Pe, enter some text.
  • Save onto Desktop.
  • Leave Pe open and move the newly created file.

--> Bam!

[tcsetpgrp failed in terminal_inferior: Invalid Argument]
Thread 196 caused an exception: Segment violation
[...]
[Switching to team /boot/system/Tracker (118) thread w>/boot/home/Desktop (196)]
0x00515222 in BPrivate::Model::IsNodeOpen ()
   from /boot/system/lib/libtracker.so
(gdb) BT
#0  0x00515222 in BPrivate::Model::IsNodeOpen ()
   from /boot/system/lib/libtracker.so
#1  0x00529c57 in BPrivate::BPose::Draw () from /boot/system/lib/libtracker.so
#2  0x005307e8 in BPrivate::BPoseView::MakeDragBitmap ()
   from /boot/system/lib/libtracker.so
#3  0x00530bd8 in BPrivate::BPoseView::DragSelectedPoses ()
   from /boot/system/lib/libtracker.so
#4  0x0053d4ea in BPrivate::BPoseView::MouseDown ()
   from /boot/system/lib/libtracker.so
#5  0x00365049 in BWindow::DispatchMessage () from /boot/system/lib/libbe.so
#6  0x00361359 in BWindow::task_looper () from /boot/system/lib/libbe.so
#7  0x002adc42 in BLooper::_task0_ () from /boot/system/lib/libbe.so
#8  0x005edd9c in thread_entry () from /boot/system/lib/libroot.so
#9  0x70184fec in ?? ()
(gdb) 

Slightly different:

  • Open Pe, enter some text.
  • Save onto Desktop.
  • Close Pe and move the newly created file.

--> Boom!

[tcsetpgrp failed in terminal_inferior: Invalid Argument]
Thread 1110 caused an exception: Segment violation
[...]
[Switching to team /boot/system/Tracker (1100) thread w>/boot/home/Desktop (1110)]
0x003b2365 in BList::ItemAt () from /boot/system/lib/libbe.so
(gdb) bt
#0  0x003b2365 in BList::ItemAt () from /boot/system/lib/libbe.so
#1  0x00527f45 in BPrivate::BPose::WidgetFor ()
   from /boot/system/lib/libtracker.so
#2  0x00528007 in BPrivate::BPose::CalcRect ()
   from /boot/system/lib/libtracker.so
#3  0x0052e8eb in BPrivate::BPoseView::GetDragRect ()
   from /boot/system/lib/libtracker.so
#4  0x00530b6a in BPrivate::BPoseView::DragSelectedPoses ()
   from /boot/system/lib/libtracker.so
#5  0x0053d4ea in BPrivate::BPoseView::MouseDown ()
   from /boot/system/lib/libtracker.so
#6  0x00365049 in BWindow::DispatchMessage () from /boot/system/lib/libbe.so
#7  0x00361359 in BWindow::task_looper () from /boot/system/lib/libbe.so
#8  0x002adc42 in BLooper::_task0_ () from /boot/system/lib/libbe.so
#9  0x005edd9c in thread_entry () from /boot/system/lib/libroot.so
#10 0x70184fec in ?? ()
(gdb) 

Change History (14)

comment:1 by humdinger, 10 years ago

With "move" above, I meant "drag around"...

comment:2 by anevilyak, 10 years ago

Out of curiosity, do you only see this with the desktop, or will any random folder do? Based on the backtrace I'm going to presume the latter..

comment:3 by anevilyak, 10 years ago

Milestone: R1R1/alpha2
Owner: changed from axeld to anevilyak
Priority: normalblocker
Status: newassigned

comment:4 by humdinger, 10 years ago

I tried the same with saving to /boot/home/ after opening that folder in Icon View. No crash.

After changing the icon size from 48px to 32px on the desktop, I can't reproduce the crash, even when re-setting to 48px...

comment:5 by anevilyak, 10 years ago

Hrm....will play around to see if I can replicate it after work. If you find a reliable test case before then, please let me know.

comment:6 by diver, 10 years ago

#4322 could be related.

in reply to:  6 comment:7 by anevilyak, 10 years ago

Blocked By: 4322 added
Resolution: duplicate
Status: assignedclosed

Replying to diver:

#4322 could be related.

Indeed, that looks to be the same problem. Marking this one as a duplicate.

comment:8 by anevilyak, 10 years ago

Blocked By: 4322 removed

comment:9 by anevilyak, 10 years ago

Blocked By: 4322 added

comment:10 by humdinger, 10 years ago

The first stack crawl doesn't look like #4322...

BTW, I used to be able to reproduce the crash as described above as often as I liked. Now, without updating anything, it doesn't work... It comes and goes apparently.
It would be cool if this issue could be fixed before alpha2, as a crashing Tracker is very visible and a newbie may not know he can easily restart Tracker and mistake it for a system-crash.

in reply to:  10 comment:11 by anevilyak, 10 years ago

Replying to humdinger:

BTW, I used to be able to reproduce the crash as described above as often as I liked. Now, without updating anything, it doesn't work... It comes and goes apparently.
It would be cool if this issue could be fixed before alpha2, as a crashing Tracker is very visible and a newbie may not know he can easily restart Tracker and mistake it for a system-crash.

Agreed, but there's not much I can do without a reproducible test case, the stack crawls in either case are generic enough as to be practically useless without further debugging information.

comment:12 by humdinger, 10 years ago

Yeah... I thought I had a test case... :)

comment:13 by aldeck, 10 years ago

Can't reproduce either. Btw, i'm a bit unsure about it being a duplicate of #4322. Got a few questions though, Humdinger, how crowded was your desktop? when you could reproduce, was it with a fresh build, first boot? When you say "drag around", does the crash happen on the first drag-move-drop, or do you need several?

comment:14 by humdinger, 10 years ago

I try to keep my Desktop clean :) Besides Disks and Trash there are two links and two files. The build was reasonably fresh (can't remember exactly), it definitely occured not only on first boot. The crashes appeared on first try, just after starting to move the mouse, made just a few pixels before it went down...

I haven't seen a Tracker crash for a while now. Using hrev36460 ATM.

Note: See TracTickets for help on using tickets.