Opened 9 years ago

Closed 4 years ago

#5781 closed bug (fixed)

Changing keymap settings seems to work only second time around

Reported by: stippi Owned by: axeld
Priority: normal Milestone: R1/beta1
Component: - General Version: R1/Development
Keywords: Cc: planche2k@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I have just performed a clean installation, which just links the German keymap as current keymap as the only related customization. Using the Keymap to change the command key to Ctrl and turn the Tilde key off as deadkey did not have any effect. Opening Keymap for the second time showed the settings as I configured them. I toggled the command key back and forth and also the Tilde key on/off, and now my settings have been applied for real. Could this be a problem not with the recent keymap refactoring, but with the changes to the USB keyboard add-on instead?

Change History (5)

comment:1 Changed 9 years ago by stippi

Of course I forgot to mention the revision, it's hrev36421 on real hardware. GCC4 based hybrid.

comment:2 Changed 9 years ago by andreasf

Cc: planche2k@… added

comment:3 Changed 9 years ago by stippi

The last time I installed the alpha (on my notebook) I didn't seem to have this problem. Could this be a USB keyboard only problem?

comment:4 Changed 8 years ago by scottmc

Milestone: R1/alpha3R1/beta1

Does this still happen? Sliding this to R1/beta1.

comment:5 Changed 4 years ago by pulkomandy

Resolution: fixed
Status: newclosed

Can't reproduce even with an USB keyboard, assuming fixed...

Note: See TracTickets for help on using tickets.