Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5782 closed bug (fixed)

multiple undefined references when building gcc2

Reported by: mmadia Owned by: zooey
Priority: blocker Milestone: R1/alpha2
Component: Build System Version: R1/Development
Keywords: Cc: planche2k@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Disreali noticed this on IRC. hrev36423-gcc2hybrid r1a2-rc Here's some undef ref's when building Haiku gcc2 within Haiku.

(.gnu.linkonce.t.__tf10PrecacheIO+0x29): undefined reference to `__rtti_si'
(.text+0xf934): undefined reference to `__dynamic_cast'
(.gnu.linkonce.t.__tft24SinglyLinkedListLinkImpl1Z17DeferredDeletable+0x1f): undefined reference to `__rtti_user'
(.text+0x6f34): undefined reference to `__builtin_delete'
...

Attachments (1)

log.txt (81.5 KB ) - added by mmadia 9 years ago.

Download all attachments as: .zip

Change History (5)

by mmadia, 9 years ago

Attachment: log.txt added

comment:1 by andreasf, 9 years ago

Cc: planche2k@… added

comment:2 by zooey, 9 years ago

Status: newin-progress

Confirmed that it's a problem with the libgcc.a of the new gcc2 version.

Trying to find the cause of the problem.

comment:3 by zooey, 9 years ago

Resolution: fixed
Status: in-progressclosed

Strangely enough, libgcc.a in that gcc2-build did not contain the files required for C++ support. Rebuilding gcc2 fixed the problem (why on earth ...).

Fixed in hrev36434.

comment:4 by Disreali, 9 years ago

Thanks. The new gcc2 allowed trunk to build without issues.

Note: See TracTickets for help on using tickets.