Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#58 closed bug (fixed)

PANIC: vnode 4:327684 already exists

Reported by: adeynichenko@… Owned by: axeld
Priority: high Milestone: R1
Component: System/Kernel Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

KDL after StyledEdit start (bootlog included):

PANIC: vnode 4:327684 already exists (node = 0x8042f400, vnode->node = 0x803c2200)! Welcome to Kernel Debugging Land... Running on CPU 0 kdebug> sc iframe 0x84e04fac (end = 0x84e05000) iframe 0x84e04fac (end = 0x84e05000) stack trace for thread 0x4a "StyledEdit"

kernel stack: 0x84e03000 to 0x84e05000

user stack: 0x7efe7000 to 0x7ffe7000

frame caller <image>:function + offset 84e045a4 (+ 48) 80072ab1 <kernel>:kernel_debugger_loop + 0x0109 84e045d4 (+ 32) 80072fc6 <kernel>:kernel_debugger + 0x0092 84e045f4 (+ 176) 80072f2a <kernel>:panic + 0x0036 84e046a4 (+ 64) 8003fc61 <kernel>:new_vnode + 0x0059 84e046e4 (+ 64) 801be94f <bfs>:New14InodeAllocatorP9block_runUiR9block_runPP5Inode + 0x011f 84e04724 (+ 176) 801c4879 <bfs>:Create5InodeR11TransactionP5InodePCcliUlPxPP5Inode + 0x05f9 84e047d4 (+ 96) 801cdda0 <bfs>:bfs_create_dirFPvT0PCciPx + 0x0170 84e04834 (+ 336) 800419a9 <kernel>:dir_createFiPcib + 0x0071 84e04984 (+1072) 800460a0 <kernel>:_user_create_dir + 0x0048 84e04db4 (+ 336) 8002f1d3 <kernel>:syscall_dispatcher + 0x0897 84e04f04 (+ 160) 80077b73 <kernel>:i386_handle_trap + 0x0243 iframe at 0x84e04fac

eax 0x4b ebx 0x753384 ecx 0x3 edx 0x7ffe6728 esi 0x7ffe68f4 edi 0x1801dde8 ebp 0x7ffe6750 esp 0x84e04fdc eip 0x6fab87 eflags 0x213 vector: 0x63, error code: 0x0

7ffe6750 005c1c72 7ffe6780 005a5d8f 7ffe6910 005d7f2f 7ffe69a0 005d77ef 7ffe6be0 005d4cde 7ffe6d10 005d2f69 7ffe6da0 0020e94a 7ffe6e30 0020f556 7ffe6f80 0020c2f4 7ffe6fac 00100661 7ffe6fdc 7ffe6fec

Attachments (1)

vnode_bootlog.txt (61.8 KB) - added by adeynichenko@… 13 years ago.
vnode_bootlog.txt

Download all attachments as: .zip

Change History (5)

Changed 13 years ago by adeynichenko@…

Attachment: vnode_bootlog.txt added

vnode_bootlog.txt

comment:1 Changed 13 years ago by jackburton

This seems to be fixed. At least, I can't reproduce it anymore. Alexander, can you confirm ?

comment:2 Changed 13 years ago by adeynichenko@…

Status: newclosed

comment:3 Changed 13 years ago by adeynichenko@…

Resolution: fixed

comment:4 Changed 13 years ago by adeynichenko@…

can't reporoduce at latest build

Note: See TracTickets for help on using tickets.