Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#59 closed bug (fixed)

user debugger window bad behaviors

Reported by: korli Owned by: bonefish
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

  • the user debugger window isn't scrollable, thus making hard to view long

stacktraces.

  • the user debugger keeps running when closing the user debugger window with the

top left Close button.

  • the debugger() call in libroot.so doesn't bring up the user debugger as in R5.

Change History (7)

comment:1 by bonefish, 14 years ago

Status: newassigned

comment:2 by bonefish, 14 years ago

  • We're still using the MiniTerminal since there were stability problems with

the real Terminal. You can display only the first n frames of a stack trace by "bt n", BTW.

  • Mmh, OK, might be a MiniTerminal issue, too.
  • I tested that with src/tests/servers/debug/crashing_app and it work fine

there. In what context did you experience that?

comment:3 by korli, 14 years ago

  • makes sense :)
  • yes
  • yes a test terminal app works fine. But some complex apps sometimes make a

call to BLooper::check_lock() which fails, debugger() is called and fails to bring the user debugger: I'll give you more details on how to reproduce this.

comment:4 by korli, 14 years ago

I can't reproduce the third item, to be considered fixed.

comment:5 by korli, 14 years ago

Status: assignedclosed

comment:6 by korli, 14 years ago

Considered closed as we moved to Terminal

comment:7 by korli, 14 years ago

Resolution: fixed
Note: See TracTickets for help on using tickets.