Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5820 closed bug (fixed)

[Installer] window is getting way to wide

Reported by: diver Owned by: korli
Priority: normal Milestone: R1
Component: Applications/Installer Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description



After translating "Set up boot menu" Installer window will be even wider.
Tested with hrev36482.

Attachments (2)

installer.2.png (35.1 KB) - added by diver 9 years ago.
installer.png (35.1 KB) - added by diver 9 years ago.

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by diver

Attachment: installer.2.png added

Changed 9 years ago by diver

Attachment: installer.png added

comment:1 Changed 9 years ago by diver

BTW, some other apps/preflets suffer from this issue. While they are compact in English locale the become huge in some languages.

comment:2 Changed 9 years ago by stippi

Resolution: fixed
Status: newclosed

It's the job of the translators to find adequate strings that don't let the panels become huge in size. However, I can see how this would become exceedingly difficult with the Installer. I've moved the functionality into a new Tools menu in hrev36484. This makes the options also less prominent, which is a good thing, as most users should not need them.

comment:3 Changed 9 years ago by diver

Thanks, it's much better now, it also uncovered several other bugs :-)

comment:4 in reply to:  2 Changed 9 years ago by Karvjorm

Replying to stippi:

It's the job of the translators to find adequate strings that don't let the panels become huge in size. However, I can see how this would become exceedingly difficult with the Installer. I've moved the functionality into a new Tools menu in hrev36484. This makes the options also less prominent, which is a good thing, as most users should not need them.

The problem is that translators do not always know the context of the text in a application. They can see it first when running the localized application (or preflet). So it can take time.

Note: See TracTickets for help on using tickets.