Opened 9 years ago

Closed 9 years ago

#5851 closed bug (duplicate)

Kernel Panic on boot

Reported by: mbrumbelow Owned by: bonefish
Priority: critical Milestone: R1/alpha2
Component: Drivers/ACPI Version: R1/Development
Keywords: acpi Cc: fredrik.holmqvist@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Kernel panics on boot in builds hrev36511 and later changesets. Tested on 2 HP & 2 DELL laptops. Selected ACPI as the component due to where KDL lands... "acpi_task" running on CPU 0 (see attachment).

Attachments (1)

photo.jpg (102.3 KB) - added by mbrumbelow 9 years ago.
Screenshot of kernel panic @ boot

Download all attachments as: .zip

Change History (9)

Changed 9 years ago by mbrumbelow

Attachment: photo.jpg added

Screenshot of kernel panic @ boot

comment:1 Changed 9 years ago by anevilyak

Owner: changed from nobody to tqh
Status: newassigned

comment:2 Changed 9 years ago by axeld

Looks like the acpi_task is started too early. Did you enable the I/O APIC by any chance?

Also, the back trace of the main thread would be interesting. "sc 1" should do the trick here.

comment:3 in reply to:  2 Changed 9 years ago by bonefish

Replying to axeld:

Looks like the acpi_task is started too early.

Fixed unnecessary problems with early resume_thread() invocations in hrev36530.

comment:4 Changed 9 years ago by tqh

Cc: fredrik.holmqvist@… added
Owner: changed from tqh to nobody

Please test a revision after hrev36530. (Not sure I'm able to handle this bug so setting unassigned).

comment:5 Changed 9 years ago by bonefish

Milestone: R1R1/alpha2
Owner: changed from nobody to bonefish

Assigning to myself. Maybe I'll find the time to look into it before the alpha 2 release.

comment:6 Changed 9 years ago by tqh

Is this same as #5861, I'd think so. mbrumbelow, let us know so we can close if possible.

comment:7 Changed 9 years ago by mbrumbelow

tqh, your right this is the same as #5861. This ticket can be closed.

comment:8 Changed 9 years ago by tqh

Resolution: duplicate
Status: assignedclosed

Duplicate of #5861.

Note: See TracTickets for help on using tickets.