Opened 9 years ago

Closed 9 years ago

#5915 closed bug (fixed)

KDL while extracting zip files using unzip

Reported by: streak Owned by: axeld
Priority: high Milestone: R1/alpha3
Component: File Systems/BFS Version:
Keywords: Cc:
Blocked By: Blocking: #6055
Has a Patch: no Platform: All

Description

KDL while extracting zip files using unzip.

How to reproduce: use haiku hrev36601 download -> http://qt-haiku.ru/index.php?option=com_rokdownloads&view=file&task=download&id=64%3Aqt-4-5&Itemid=60 -> "Qt 4.5.1 for Haiku hrev127 (minimal)" try to extract it onto haiku /boot partition

KDL from extracting zip file: http://img685.imageshack.us/img685/9601/kdlwhileextractingfileq.jpg

Attachments (2)

panicvnodealreadyexist.jpg (473.7 KB ) - added by damoklas 9 years ago.
Panic by extracting downloaded xz-utils, haiku-r1a2-rc-hrev36724.
panicbygoogle.jpg (461.4 KB ) - added by damoklas 9 years ago.
By Web+ on haiku-r1a2-rc-hrev36737-x86gcc2hybrid

Download all attachments as: .zip

Change History (10)

comment:1 by streak, 9 years ago

I noticed that its not only occurs while extracting, so definitelly it should be 100% reproductable.

I've get it while moving files from BFS -> BFS

Here's new screenshot: http://img408.imageshack.us/img408/1134/kdlwhilemovingfiles.jpg

comment:2 by streak, 9 years ago

Priority: normalhigh

comment:3 by michaelvoliveira, 9 years ago

Only this week, I crashed Haiku more than the last seven months....

comment:4 by bonefish, 9 years ago

Tested twice under hrev36724 (trunk) gcc2hybrid without any crash. My guess is that the BFS volume you're testing with has a certain property (corruption or just a special case) that causes BFS to trip. Anything BFS related in the syslog (syslog | tail in KDL)?

comment:5 by Ziusudra, 9 years ago

Related to #3151?

by damoklas, 9 years ago

Attachment: panicvnodealreadyexist.jpg added

Panic by extracting downloaded xz-utils, haiku-r1a2-rc-hrev36724.

by damoklas, 9 years ago

Attachment: panicbygoogle.jpg added

By Web+ on haiku-r1a2-rc-hrev36737-x86gcc2hybrid

comment:6 by bonefish, 9 years ago

Blocking: 6055 added

(In #6055) Duplicate of #5915.

comment:7 by streak, 9 years ago

not occuring , can be closed..

in reply to:  7 comment:8 by scottmc, 9 years ago

Resolution: fixed
Status: newclosed

Replying to streak:

not occuring , can be closed..

Closing as probably fixed then.

Note: See TracTickets for help on using tickets.