Opened 9 years ago

Closed 7 weeks ago

#5917 closed bug (fixed)

Track's duplicate handling does not work if blocking already set

Reported by: axeld Owned by: haiku-web
Priority: normal Milestone:
Component: Website/Trac Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

If the original ticket is already blocking the duplicate, one cannot close the duplicate as duplicate anymore, before having manually removed the blocking in the original ticket.

IOW it notices that the ticket is already in there, but instead of silently accepting this, it fails to update the duplicate's resolved status.

Change History (1)

comment:1 Changed 7 weeks ago by waddlesplash

Resolution: fixed
Status: newclosed

The first aspect of this is intended behavior; you can't close a ticket with "blocked by" in it that are still open, as it's blocked by those. However you can now edit the "blocked by" at the same time as resolving the ticket, instead of having to modify the other ticket first, so this is resolved insofar as it can be.

Note: See TracTickets for help on using tickets.