Opened 7 years ago

Closed 5 years ago

#5961 closed bug (fixed)

Haiku keeps reverting to DHCP

Reported by: Daniel Owned by: axeld
Priority: normal Milestone: R1
Component: Preferences/Network Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

For some reason Haiku can't get an IP from my wireless router, so I set my card to static, in the networks preflet. But even after doing that, no matter how many times, Haiku keeps changing my card back to DHCP, which results in me losing connectivity (since it gets only a 169.xxxxx IP address).

Attachments (2)

interfaces.zip (352 bytes) - added by Daniel 7 years ago.
interfaces.2.zip (352 bytes) - added by Daniel 7 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 7 years ago by Daniel

Forgot to mention that it's not Alpha 2 specific, it has happened ever since wifi has worked on my card (few months ago, thanks to Colin's work).

comment:2 Changed 7 years ago by Rene Gollent

Component: Network & InternetServers/net_server
Owner: changed from Nobody to axeld

comment:3 Changed 7 years ago by axeld

Component: Servers/net_serverPreferences/Network
Version: R1/alpha2R1/Development

The network preferences application looks severly broken for more than one adapter.

It should work flawlessly if you use "ifconfig" from a Terminal to set the static configuration, does it?

In any case, could you attach your /boot/common/settings/network/interfaces file that the Network preferences application created?

Changed 7 years ago by Daniel

Attachment: interfaces.zip added

Changed 7 years ago by Daniel

Attachment: interfaces.2.zip added

comment:4 Changed 7 years ago by Daniel

Axel, thanks for the tip. Setting the interface to static via ifconfig seems to have helped. At least I've been online for 2 whole minutes now :)

As you requested, I'm attaching the interfaces file.

P.S.: Sorry for the double attachment, Web+ gave me an error when trying to upload the file but it seems to have done it.

comment:5 Changed 7 years ago by Daniel

It seems I spoke too soon (though I'll test it again ASAP). Few minutes after being online for one hour straight, I lost connection. ifconfig still gave me the same settings but I couldn't go anywhere. I tried setting it to auto and static once again (all via Terminal) but no go.

comment:6 Changed 7 years ago by Rene Gollent

That sounds like a different problem from the original, since if DHCP had been the culprit in this instance, you would've seen ifconfig revert back to a 169.254.x.x IP.

comment:7 Changed 7 years ago by jim saxton

For me, the dhcp aquires an IP ... then re-aquires ... forcing me to close the browser and re start it. Seting to static does not reesolve the problem as it will re-aquire an ip anyway.

This only happens if the wifi detects more than one wireless connection.

comment:8 Changed 6 years ago by Philippe Houdoin

Does the issue still present after the net_server DHCP changes made since?

comment:9 Changed 5 years ago by Daniel

This doesn't happen anymore, this ticket can be closed.

comment:10 Changed 5 years ago by diver

Resolution: fixed
Status: newclosed

Closing, thanks for the feedback.

Note: See TracTickets for help on using tickets.