Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#5981 closed bug (invalid)

Maximizing WebPositive makes window decoration disappear

Reported by: svroemisse Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

This happened to me running both from the live cd and from hdd: I clicked the maximize button and the window decoration went away. There is no more window border or title. The window did maximize though, sort-of mimicking full screen mode. This doesn't happen with any other application.

Change History (15)

comment:1 by Ziusudra, 9 years ago

Platform: x86-64x86

This is the intended behavior.

And WonderBrush does the same.

comment:2 by stippi, 9 years ago

Resolution: invalid
Status: newclosed

It's a feature!

comment:3 by diver, 9 years ago

Then it would be nice to make this feature configurable...

comment:4 by stippi, 9 years ago

Can someone explain what is useful about a "maximized" window that is still movable/resizable? I am probably missing something. :-)

comment:5 by tangobravo, 9 years ago

I thought WonderBrush had a separate "Full Screen" button in its menu bar? I'd probably prefer that approach, it is a bit unexpected to take over the entire screen on "Zoom".

I guess that's what media player's video windows do though, which is entirely expected behaviour in that case. Maybe it's my expectations that are wrong :)

Why is it useful: I don't really know...but it's not a decision that a single app should take.

I guess "Zoom" usually makes windows as big as they need to be, but no bigger. That's hard to decide in a browser, so maximise seems the thing to do. I suppose with slidable tabs there might be some use in multiple maximised windows.

Still, the best argument for putting the full screen functionality into its own widget is one of consistency IMHO.

comment:6 by diver, 9 years ago

+1

comment:7 by stippi, 9 years ago

I am not convinced yet. The "zoom" button has always been an "alternative size" button. Not a "maximize" button. So that a window maximizes when pressing it should not be the expected behavior, rather it should be expected that the button changes to an alternative window size that makes sense and is most useful. In MediaPlayer, it's obviously to take over the complete screen. Why should reading web pages full-screen still waste space and attention on the window border? I really don't understand why that is useful. Perhaps with multiple full-screen windows and tab sliding. But that involves so much manual interaction by the user (as long as the system doesn't offer this as global concept), that I don't think manually resizing the window is much of an extra step. I'd really rather have the full-screen option that users will enjoy most, like in a media center type of situation, or just reading websites without any distraction, as the most easily accessible feature.

comment:8 by humdinger, 9 years ago

May I suggest another use of the zoom button: http://mmlr.dyndns.org/ticket/18

"The zoom button (Ctrl+Alt+Z) could resize a page to the minimal size that avoids scrollbars."

Maybe the widget appearing when using fullscree mode, that reverts back to window mode, should always be there to toggle between those modes.

BTW, one thing that can be a bit annoying: when Deskbar's auto-raise feature is activated, it's hard to aim for the window-mode widget with rising Deskbar. A possible solution would be to have some panel fade in when the mouse touches the top edge, where you could click to switch to window-mode. Chrome does something like that.

in reply to:  description comment:9 by pfaffoliver@…, 9 years ago

I don't like it either, if your not willing to change the standard behavior at the very least please provide an option to turn this 'feature' off.

comment:10 by axeld, 9 years ago

There are apps like ShowImage which differentiate between full screen mode, and zooming to somewhat full screen. I don't see how this would make any sense, personally. There are other apps like the MediaPlayer who switch to full screen.

The zoom button used to switch between window sizes/positions that make sense. For an application like ShowImage, it could resize the window to fit its contents (then a separate full screen mode would be okay again), even though I think full screen would be more useful - for Tracker, though, that function is just great, and nicely fits spatial browsing.

For an application like a browser or a media player, I think the full screen mode is definitely the one most sensible.

IOW I fully agree with stippi here, and I think ShowImage should be changed to enter full screen mode in that case as well. I also think that it would be nice to be able to leave full screen mode with the mouse again, though, and the overlay mentioned by humdinger sounds like a good solution to me.

comment:11 by stippi, 9 years ago

Clicking the menu bar usually works to bring a window to the front. It also work in WebPositive fullscreen mode, but for some reason not with the Deskbar after it auto-raised. Also when it's in always on top mode, it would be impossible to reach the icon either. Any suggestions?

comment:12 by humdinger, 9 years ago

Any suggestions?

Beyond the pop-up overlay... not much. You could check if it's hidden and move the widget to a position where it's visible, but that's bit hacky, tight?
Also, this won't help you if you have the Deskbar as a bar at the top of the screen...

comment:13 by stippi, 9 years ago

Maybe the WebPositive window should just come to front itself after a while, or when clicking anywhere inside it when it's in fullscreen mode. Since the fullscreen mode is really meant as full-screen exclusive mode, maybe that makes the most sense.

comment:14 by axeld, 9 years ago

Sounds like it would make sense indeed. It's just sad that the application has to implement that itself; it would be nicer if the system could deal with this automatically somehow.

Also, the problem with the window not getting activated when the Deskbar auto-raised over it sounds like a bug that is worth investigating. Maybe someone should open a ticket for it :-)

comment:15 by jstressman, 8 years ago

Just updating to mention that this bug is still present in hrev43809

The trick here is that although Deskbar stays on top even when you're clicking in the Web+ window, so that you can't get to the button to go back to windowed mode, other applications like Launchbox work just fine in auto-raise mode, dropping back behind Web+ when you click on the Web+ window anywhere.

(As humdinger pointed out to me, you can still toggle fullscreen by either using the menu View -> Fullscreen, using the F11 key, or using the Alt-Enter hotkey combo.)

Last edited 8 years ago by jstressman (previous) (diff)
Note: See TracTickets for help on using tickets.