Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6016 closed bug (invalid)

tcsetpgrp failed in terminal_inferior: Invalid Argument

Reported by: rcrodgers Owned by: nobody
Priority: normal Milestone: R1
Component: - General Version: R1/alpha2
Keywords: tcsetpgrp Cc: mspreij@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

A few days ago, I updated my Haiku R1 Alpha 1+ build (I had a relatively recent build based on more current sources than the R1A1 tag in the repository, but I don't recall the revision number) to Alpha 2, but I didn't attempt to do any testing or development until today. I build to a partition, so it gets wiped when building. I will do a "jam clean", rebuild, and try again, but I wanted to bring this up before doing so. A lot of the tests I've been doing with some experimental Themis code has resulted in this error, but doing a search of the Haiku Trac database for "tcsetpgrp" seems to turn up a number of bug reports all mentioning this error, but looking at one component or another as the source.

Could the problem be with tcsetpgrp itself? I have no idea what tcsetpgrp() does or exactly where it's located, but it seems to be at the center of a number of bugs filed. For reference purposes, see bugs 5657, 5676, 5712, 5741, 5755, 5780 (marked duplicate of 4322), 5781, 5920 (marked duplicate of 4175), 5938, and most recently 5959.

Attachments (2)

bt1.txt (1.6 KB ) - added by rcrodgers 9 years ago.
Backtrace 1
bt2.txt (2.5 KB ) - added by rcrodgers 9 years ago.
Backtrace 2

Download all attachments as: .zip

Change History (10)

comment:1 by luroh, 9 years ago

When at the gdb prompt, type bt to get a stack trace of the crash.

Oh, and I find jam clean utterly useless, better remove the generated/ folder instead.

by rcrodgers, 9 years ago

Attachment: bt1.txt added

Backtrace 1

by rcrodgers, 9 years ago

Attachment: bt2.txt added

Backtrace 2

comment:2 by rcrodgers, 9 years ago

Attached two text files containing backtrace information from two different occurances of this error. The crashes occurred in different places due to complexity of web page being accessed via Themis.

This output was recorded after a fresh build of R1 Alpha 2 (I removed the generated directory). This is with a gcc 2 build by the way.

comment:3 by mmlr, 9 years ago

Resolution: invalid
Status: newclosed

The error you mention is not the actual crash. It is an error that comes up during the gdb startup but it is non-critical and hasn't anything to do with the reason for the crash which is stated way above that line before the library loading section (segfaults for example). It means terminal control set process group btw. Since it happens for all gdb invokations it is naturally present in all the gdb backtraces here in trac. Since you cut the actual crash messages out in the attachements I can't tell what's really happened, from the backtraces it looks like both are inside your projects code though, so I'm closing this one as invalid as it is unlikely to be a haiku problem.

comment:4 by rcrodgers, 9 years ago

Thanks for the response, but I'd still be concerned: a call to BWindow::SetTitle(), as in the second back trace, shouldn't result in an application crash. Nonetheless, will look into it. According to the individual that wrote the experimental code, it seems to work fine on BeOS R5, which I don't have access to. (My hardware is too new for R5.)

in reply to:  4 comment:5 by anevilyak, 9 years ago

Replying to rcrodgers:

Thanks for the response, but I'd still be concerned: a call to BWindow::SetTitle(), as in the second back trace, shouldn't result in an application crash.

It most certainly should, if it's called via a NULL or otherwise invalid BWindow pointer.

comment:6 by bonefish, 9 years ago

Just FYI, IIRC the reason for the error message is the following: gdb calls tcsetpgrp() with the process group of the debugged team. Since gdb's terminal is not the controlling terminal of the debugged team, the call (correctly) fails. So that always happens when a gdb is attached to a team (e.g. via the crash dialog). When a program is started by gdb (e.g. gdb my_program), the message won't be printed. The gdb port might be buggy/incomplete with respect to terminal handling, but this is utterly harmless and has nothing to do with any crashes.

comment:7 by mspreij, 9 years ago

Cc: mspreij@… added

I can't add much to this discussion (over my head) but thought I might mention..

I'm getting the same message near the end of the installation process of the torrented ISO. I am installing on VirtualBox, the previous Alpha release installed and ran without problems on it. So, recent VBox, clean install from downloaded ISO, but I can't get past that error. Are there VBox hardware settings I should try changing? Screenshot: http://mech.cx/var/tmp/haiku_alpha_2_install_error.png

in reply to:  7 comment:8 by anevilyak, 9 years ago

Replying to mspreij:

I can't add much to this discussion (over my head) but thought I might mention..

That's ticket #6018.

Note: See TracTickets for help on using tickets.