Opened 9 years ago

Closed 7 years ago

Last modified 10 months ago

#6022 closed bug (fixed)

Haiku R1 Alpha 2 freezes after boot if ACPI is on

Reported by: TCH Owned by: tqh
Priority: normal Milestone: R1
Component: Drivers/ACPI Version: R1/alpha2
Keywords: ACPI freeze Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

If i set ACPI on, Haiku freezes after boot. The desktop comes up, and after 5-10 seconds, Haiku freezes.

If i set ACPI off, Haiku works properly.

Syslog and listdev files attached.

(syslog contains two sessions, one with ACPI on and one with ACPI off)

Attachments (3)

syslog (164.7 KB) - added by TCH 9 years ago.
syslog file
listdev.txt (3.2 KB) - added by TCH 9 years ago.
listdev output
DSC00030.JPG (404.9 KB) - added by leszek 9 years ago.
KDL

Download all attachments as: .zip

Change History (19)

Changed 9 years ago by TCH

Attachment: syslog added

syslog file

Changed 9 years ago by TCH

Attachment: listdev.txt added

listdev output

comment:1 Changed 9 years ago by leszek

Same problem here with my eeePC 701. But instead of a direct freeze after 5-10 seconds it freezes on a random base. (Completely no KDL) Syslog says nothing about the freeze.

comment:2 Changed 9 years ago by bonefish

Can you enter KDL via Alt-SysReq-D?

comment:3 Changed 9 years ago by TCH

If i fall to KDL before the computer freezes, it works. But if it freezed, it doesn't work in any way.

comment:4 Changed 9 years ago by leszek

Here a KDL I got while installing hrev37035 from usb stick. I don't know if it is related to this bug. But it seems to be a random bug just like this one with acpi. Hmm... maybe a ath (wlan chip) powermanagement issue ?

Changed 9 years ago by leszek

Attachment: DSC00030.JPG added

KDL

comment:5 Changed 9 years ago by tqh

leszek, that looks like a wifi issue which isn't related to this. It should be reported as its own issue.

comment:6 Changed 9 years ago by tqh

Saw your earlier comment. Might be worth it for both of you to check how to disable wifi drivers and see if that fixes it. Also it is interesting to see if your wifi devices share interrupt with other devices.

comment:7 Changed 8 years ago by scottmc

Can you recheck this with a recent Haiku build? It may have been fixed recently.

comment:8 Changed 8 years ago by scottmc

Blocking: 7665 added

comment:9 Changed 8 years ago by TCH

I cannot promise anything, since i am short on time, but i'll try to test it out in this weekend. Can you please tell me, where can i download a CD image with the latest build?

comment:11 Changed 8 years ago by TCH

Sorry guys, still produces standard windows behaviour. (Freezes to death.) Actually now even the desktop is unreachable, Haiku freezes middle in the boot.

comment:12 Changed 8 years ago by TCH

Any idea what should i do? What options should i set? What logs i should provide?

comment:13 Changed 7 years ago by tqh

Closing this as it is probably fixed with 'irq routing fixes' a long time ago and the info is quite old now. Report a new bug if it is still a problem.

comment:14 Changed 7 years ago by tqh

This might be related to #8111, patch is applied in hrev44025. Please test with nightly that has this change.

comment:15 Changed 7 years ago by tqh

Resolution: fixed
Status: newclosed

Setting to fixed, reopen if not.

comment:16 Changed 10 months ago by waddlesplash

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.