Opened 9 years ago

Closed 15 months ago

Last modified 14 months ago

#6050 closed bug (invalid)

Haiku won't boot, just stays on haiku splash screen

Reported by: xray7224 Owned by: rudolfc
Priority: normal Milestone: R1
Component: Drivers/Graphics/nVidia Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Hello,

I have put hiaku hrev1/alpha2 on a pendrive and booted from it, it boots up and then when it should go from the black haiku boot screen it just stays there. I have taken the syslog from the pendrive and attached it to give some indecation, i tried the verbose debug mode and reported a bug with it but apparently the bug i reported was due to the debug mode so i am reporting a new one without using any failsafe modes or any debug modes just a normal boot.

Attachments (2)

syslog (367.2 KB ) - added by xray7224 9 years ago.
System log
haiku-kernel-debug-output.txt (755 bytes ) - added by xray7224 9 years ago.
Output from kernel debugging land on app-server thread output

Download all attachments as: .zip

Change History (17)

by xray7224, 9 years ago

Attachment: syslog added

System log

comment:1 by bonefish, 9 years ago

The only issues I see in the syslog are these:

7280	KERN: usb error control pipe 30: timeout waiting for queued request to complete
7281	Last message repeated 1 time
7282	KERN: usb error ohci -1: error while setting device address
7283	KERN: usb error control pipe 30: timeout waiting for queued request to complete
7284	Last message repeated 2 times
7285	KERN: usb error ohci -1: error while setting device address
7286	KERN: usb hub 26: port 1 disabled
7287	KERN: usb hub 26: port 2: new device connected
7288	KERN: usb hub 7: port 2: device removed
...
7352	KERN: usb error control pipe 33: timeout waiting for queued request to complete

Other than that (whatever it means) everything seems to go according to plan. Even media and midi server are started, which happens after starting Tracker and Deskbar.

Apparently you have an OHCI USB controller, so I suppose entering the kernel debugger (via Alt-SysReq-D) wouldn't work anyway. Do you have a PS/2 keyboard you could try that with?

comment:2 by xray7224, 9 years ago

Yeh, i have a PS2 keyboard. I have plugged it in and left it boot up to the point where it just seems to hang and then i've done the Alt-SysReq-D and i have the kernel debug window, what would you like me to get for you ?

in reply to:  2 comment:3 by bonefish, 9 years ago

Replying to xray7224:

Yeh, i have a PS2 keyboard. I have plugged it in and left it boot up to the point where it just seems to hang and then i've done the Alt-SysReq-D and i have the kernel debug window, what would you like me to get for you ?

Please enter teams to get a list of the running teams. Should the app server be among those, please also enter threads <id> (replace <id> with the ID of the app server team). You can leave KDL via continue.

Assuming that the syslog daemon is running, after a few seconds the output of the KDL session should have been written to the syslog and after a few more seconds it should be safely on disk. Please attach the KDL session part of the syslog. Or, if that is more convenient, pictures of the screen are fine, too.

comment:4 by xray7224, 9 years ago

It didn't seem to save to the system log so i wrote it out manually in a .txt file, i have attacked that with this, i hope its useful (by the way the syslog-deamon is running).

Hope it helps

by xray7224, 9 years ago

Output from kernel debugging land on app-server thread output

comment:5 by xray7224, 9 years ago

I've worked out where the problem lies, i held down spacebar to go to the menu and then i disabled use of other graphics drivers so it defaulted to VESA. The system boots fine, its obviously something to do with the graphics driver then. I have a nvidia GeForce 8300 GS.

comment:6 by xray7224, 9 years ago

Just thought i'd mention that the problem still occurs on newer nightly builds, i can confirm that using the nightly build 37258

comment:7 by Ziusudra, 9 years ago

Component: - GeneralDrivers/Graphics/nVidia
Owner: changed from nobody to rudolfc

Probably something to do with having one nVidia that is supported (03d0 C61) and one that isn't (0423 G86).

Let's see if we can get Rudolf's input.

comment:8 by xray7224, 9 years ago

I can confirm that if i disable my 03d0 C61 nvidia card in the BIOS it i will boot and use the VESA drivers. I confirmed this using haiku nightly hrev37453

comment:9 by scottmc, 8 years ago

Blocking: 7665 added

comment:10 by rudolfc, 4 years ago

IF this still is actual, please remove the G86 card and see if the systems boots up normally, with driver, then.

If your G86 is the primary card as seen by the computer hardware (initial screen is there, BIOS and such), then the other card is not coldstarted by it's BIOS.

This will probably why things go wrong: the Nvidia driver (only) sees this other card which it supports and tries to use it. Since it wasnt'coldstarted, it will remain black.

Unless coldstarting is supported by the nVidia driver for that specific card. This you can test by enabling coldstarting the cards by the driver (it's a driver option in nv.settings).

If you run with DVI or HDMI output chances are you are in bad luck, as there's no good enough info available to coldstart these connections. Analog (VGA) style connected screens have a bigger chance of being able to being coldstarted..

Please update the info here if possible. Otherwise I think it's safe to close this ticket as there is no (big) chance we will be able to fix this. (We could create a driver for that other card though, but still then there's the chance the 'wrong' card gets inited... Though for selection I also have a nv.settins item I think I remember).

Bye!

Rudolf.

comment:11 by waddlesplash, 2 years ago

Adding boot-failure keyword to all relevant still-open tickets.

comment:12 by waddlesplash, 2 years ago

Adding "boot-failure" keyword to all relevant tickets (try 2?)

comment:13 by waddlesplash, 2 years ago

Adding "boot-failure" keyword to all relevant tickets (try 3?!)

comment:14 by rudolfc, 15 months ago

Resolution: invalid
Status: newclosed

Assuming the problem is solved in the meantime and/or it was as I was thinking with the two nVidia cards: removing the non-supported card / coldstarting related thing. Coldstarting can't be fixed I'd say. Closing ticket. Please re-open if needed.

comment:15 by waddlesplash, 14 months ago

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.